Enter piano roll at player head position?

Hey guys,

Is it possible to enter the piano roll of a midi clip at the position of the player head? Sometimes my midi clips are long, and when I enter the piano roll for a midi clip, it always opens it at the start of the clip. That’s because clicking once on a midi clip moving the player head immediately to the start position of the clip.

Maybe there’s a way to change that default behavior? Or another way?

Thanks in advance


This topic has been discussed many times here on the forum. My personal trick is to hit the F Key Command twice (Auto-Scroll disable/enable). This forces the Key Editor view to jump to the cursor position.

Hey Martin thank you very much for answering. I’m trying your trick but it doesn’t change anything maybe I misunderstand it or don’t explain my problem properly.

I’m sorry if it’s a repost, I found your answer here: MIDI Editor:Focus on playback cursor when opening a sequenc - #3 by EdCubasero

But it doesn’t work for me

I have a midi clip and I want to open it with the piano roll at bar 40:

I press on the midi clip and unfortunately the cursor moves to the start position:

When should I press F twice? Before clicking on the midi clip or after? I tried both and nothing happens.

Thanks in advance

EDIT the only thing I found that can work is that after you click on the midi clip and the position resets you can click again on the ruler at your desirable position and then enter the piano roll… but I guess with the F key it’s better?


You should press the F twice after you open the Key Editor.

But, what you are describing is maybe something different, because the cursor jumps over. Please, make sure the Transport > Use Video Follows Edit Mode is disabled on your side.

1 Like

Yes that solved it(:

I don’t even need to do the F thing because my auto-scroll is disabled already

Thank you so much Martin!