"Enter Project Cursor Position" still keeps "primary time display" up after entering value

This issue is present since Cubase Pro 10 came out and highly annoying: I use the command “enter project cursor position” a lot to jump to different positions in a project and have used this since ages. Since Cubase 10 a little window showing you entering a new position pops up whenever you’re in any editor outside of the main project window [Note: I use “open editor commands open editors in a Window”]. This little window however doesn’t disappear and has to be clicked away (either with mouse or with ESC key or so) before being able to do anything, which adds an unneeded step while working. That never happened in any Cubase version before and I consider this a bug. There’s no reason for this window to appear - I know where I want to jump (funnily the transport bar doesn’t show the entered value even with the transport bar being visible on the bottom of my window layout - that’s where it should show it).

Can this please, please, please be changed to work like it did in previous versions?!


Have you installed CUbase 10.0.20 update, please?

Hello Martin,
Sorry for the late reply. This is with 10.0.20 Built 187 already on my macOS 10.14 system here.


This bug is a workflow killer. Please fix.


This bug is present only if the Transport Bar (the most lower zone) is not present. If this part is enbaled, then while you press Shift+P (enter project cursor position), the cursor jumps to this bar. You can type the time position, press enter and you don’t have to close it.

Hi Martin-

My Transport is visible in the lower zone, yet still shows this buggy behavior.


Could you be more precise, please? Aha happens when you press Shift+P? Does the dedicated Transport Location window appear?

If any window other than the Project window is foreground, my key command will make the Transport Location window appear. After numerically typing a location value I have to hit ENTER twice before that window goes away. Pre-Cubase 10, that window never appeared upon striking my key command.

If the project window is foreground, my key command appropriately highlights the bar field within the Transport Location “strip” nested at the bottom of the project window. Hope this makes sense.


You are right, sorry.

+1 - that’s exactly what happens here as well. Just to confirm.


I reported it to Steinberg.

Thank you Martin!

@ Martin: this issue is still present in 10.0.40. I wonder if this gets addressed anytime soon? This is really slowing workflow significantly.


I’m with you, I also wish for a fix.

And still issue still has not been address in 10.5.0. We can’t be the only ones complaining about this…

Any news on if we’re ever getting a fix to this???

There are multiple threads about this. Steinberg has not fixed it to my knowledge yet. This is such a simple thing that worked fine in Cubase 9.5 and now in Cubase 10 it’s really annoying. Please please please please please fix.

This is still not working as it did back in Cubase Pro 10 or earlier versions - currently under Cubase Pro 10.5.20.
Does anybody know if Steinberg is intending to fix this at all?

Obviously I have “learned” to live with it, but boy is this annoying as hell !!

Couldn’t agree more. I’ve have spoken directly with Steinberg about it, no luck…

My only hope is that enough people on the forum see this and complain.

10.5.20 Pro, here : right after choosing Transport>Transport Commands>Enter project Cursor position (or Shift+P), I get this :

… which allows me to directly type in the cursor position. This, whether the transport panel (F2) is visible or not, and no matter the primary time display used. Evidently, there is no added window of any kind displayed. So, I guess that there is a more or less hidden setting involved, maybe in the preferences, as I have never seen the window shown in the OP… :confused: