Entering drumset notes

I’m watching this Dorico tutorial: Drum Notation Lead Sheets | Discover Dorico - YouTube
but I notice that unlike in the video, when I try to enter notes, when I hover with the mouse or use the arrow keys, I don’t get the preview of what the drum will be. The mouse hover shows where the note will be, but the hover text doesn’t change - only showing whatever the last drum was (ie. H-hat, or W.Bl.2 by default) until I click.
After I enter the note, when I click on it, I can only change the duration, but can’t change the drum with the arrows. My only option is to delete it and try again.
Drums notes test 27Apr2022.dorico (854.0 KB)
Am I missing something?

Can you change the drum note with ALT/OPT+ Arrow?

I tried a number of different keys and it turns out ctrl-up or down works.
This is interesting because I had changed my key commands so that plain up and down raises and lowers pitch chromatically, which works for notes for a regular instrument. I expected it to do something similar with drums, but apparently this isn’t the case. I wonder if that’s by design?
I did import this from XML, so just to compare, I created a brand new file with the default drumset. But in this file, I’m not seeing the shadow preview of where the note will be or even the drum name.

This isn’t normal, is it? I mean, that’s not what I’m seeing in the youtube tutorial. What should I do?

Did you check this?

Input drums with mouse

The selection arrow was off, so I turned it on. But this made it even worse because I couldn’t add notes. When I clicked, it would just select the bar or the rest and turn off input mode.
I made a video which I hope clarifies things.
Also, noticed that when I use ctrl-up/down on the keyboard, it only gives me 2 options.

Good news. I reinstalled Dorico sounds because I realized I was missing a lot of instruments from the Halion library for some reason. I wasn’t even concerned about playing it back yet, so I hadn’t even set up what instrument for that slot to play… So that’s odd and interesting.
Now I have more options when I use ctrl-up/down, and when I click on the note, I can use ctrl-up/down as well to change it to a different drum.
However, when entering a new note, I’m still not seeing the text/note placement preview that is shown in the tutorial. Wondering if this is the case for anyone else?

You can just use the up and down arrow keys to move between the different staff positions on the drum kit: Ctrl+up/down goes to the top and bottom instruments in the kit respectively, and using the arrow keys alone will allow you to navigate through all of the instruments.

Around 0:40 in the video, I try up and down (without Ctrl) but there is no hover text indication of other drums being selected for entry.

It would be incredibly useful to have the hover text to tell me what drum I’m about to input. How do I get this to happen? I don’t see this preview with either the mouse or the keyboard. I should see what’s shown in the video tutorial, right?
Any suggestions would be appreciated.

Dorico 4 Pro for Windows is what I’m using, and when I move the caret around on the drum staff I see the label for the various instruments. That’s the way my Dorico installed, I haven’t changed anything in the display. When you go to Setup mode and click on the Drum Set player and then click on the three dots to see the context-menu, select Edit Percussion Kit what do you see? On my computer I see a list of each drum in order from top to bottom, and those are the same names that appear when I move the caret for note entry up and down on the percussion staff. What instrument did you select for that player?

I’m using 3.5 Pro, but the video is from 2019, so 3.5 vs 4 shouldn’t matter.
This is a basic drumset I’ve set up:

So I can change the note using ctrl-up/down, BUT oddly only a limited selection. I can never get back to the note I started with if they’re hi-hat or kick. I made a screen cap video to show this, and also tried to enter some notes again - no hover text with either mouse or keyboard.

Clearly the changes that you made to the key commands have had some collateral effects…

I would suggest you reset to the factory defaults, learn how to do it properly, and only then make changes. There is a logic to the default key settings for the basic operations that is consistent across the program.

1 Like

In addition to what Janus said above, it looks like you are using Mouse input, which is a very inefficient way to work with Dorico. Try resetting your keycommands and then try learning either keyboard input, or MIDI input if that’s an option for you. I think you may find this will be much easier using keyboard input rather than mouse. (Personally, I virtually always use pitch before duration MIDI input.)

I totally agree with you on mouse input. I was only using it because the keys weren’t doing what I wanted.
As for key commands, changing the up/down to chromatic pitch changes is one of very few changes I’ve made (although I recognize it may have far reaching consequences), and I know I’m not alone for that one from being on the forum (Jump bar: unable to use arrows because they are set as key commands - #3 by CMS_LU).
I’ll try resetting the key commands and see what happens. Having said that, the mouse input also doesn’t do what it should (ie. text hover preview in the tutorial), so I suspect it’s not just that.


My mistake, no text on mouse input.
If this was already mentioned in this thread, please accept my heartfelt apology for the need to shout @Janus.