Entering Lyrics results in weird spacing and content

Hello,

I get following bug when entering lyrics: https://giphy.com/gifs/Ti7EYhJHzAfC9Gg25J
I already asked in the facebook forum, with no result.

As one can see, not only is the spacing wrong, but the dash is somehow still contained.

I have the dorico file and the .txt file with the lyrics attached (as one .zip)
The specific place is after the “Tempo I” marking, but it appeared throughout the score for me.
It workes properly in around 15-20% of cases, but I don’t know yet why.
piesn wieczorna.zip (573 KB)

The encoding of your text file is unusual, and I think that might be what’s tripping Dorico up. When I open your text file in a text editor, I see what looks like two hyphens separating most of the syllables, but those are not the expected hyphen character; Dorico requires that you use the regular hyphen-minus character as the separator. Try reworking your text file so that it contains just a single hyphen where needed, and use the regular hyphen-minus, and that should sort it out.

Thank you Daniel. Can you tell me, which Texteditor you used?
All my editors show me only one dash, and it’s a regular hyphen-minus, as I entered it with my keyboard. (Sorry for writing “dash”, I, of course, meant hyphen, English is not my mother tongue).

Do you also have recommendations as to where and how to edit lyrics for optimizing in Dorico?
I usually take the text, enter it or paste it in TextEdit or TextMate to have it unformatted and then enter the hyphen-minus character (-) via my keyboard. I am using a german keyboard layout, although I hope it doesn’t make a difference (because entering it manually in Dorico works with it very well).

Best

If you look at your text in a hex editor you’ll see that the hyphens (2D) are preceded by C2 AD. You will have saved your lyrics with UTF-8 encoding and C2 AD represents a SOFT HYPHEN. You are presenting Dorico with SOFT HYPHEN HYPHEN-MINUS.

Dorico could perhaps ignore SOFT-HYPHEN but you should probably use either a different encoding or different options when you save.

Apologies for the brevity of the explanation. No time…

thank you, it is perfectly understandable. For now, I just don’t know, how I got there… As I said, I entered in UTF-8 formatted .txt normal minus-hyphens via my keyboard…
I was just wondering, what I could do next time to not have this problem?

I did a little more research, and understand soft hyphens better now. Funnily, if I delete my minus hyphens, dorico ignores the soft hyphens and the full word is entered.

I also realized that the soft hyphens must have either come from the website I copied the text from or the pages document I did the translation in… no matter what, I think ignoring the soft hyphen in any case, would be helpful, wouldn’t it?