Errata in Block diagram UR28M

The FX Insert as shown in the X2 block I believe should actually be named FX Monitor (or better MON.FX (x4)). The FX Insert is correctly shown in the diagram following the input stage (but would be better named INS.FX (x4)). The renaming would be better for clarity referencing the CH Strip block x4 shown, as well as using the same naming scheme as in the signal flow diagrams and the actual software apps.