Error after upgrading from Cubase LE 4 to LE 9.5: UNEXPECTED_KERNEL_MODE_TRAP what failed: ks.sys"

Hi. I’ve used the offer on my Steinberg personal page and upgraded Cubase LE 4 to LE 9.5. The installation was successful. But then, every time I try to open the program, windows crashes with a blue screen with this error:

:frowning:
Your PC ran unto a problem and needs to restart. We’re just collecting some error info, and then we’ll restart for you.
stop code: UNEXPECTED_KERNEL_MODE_TRAP
what failed: ks.sys”

How can I fix this?

Could it be that my laptop can’t support the software?
My laptop specs:
DELL Inspiron 15R N5110 64x
Intel core i5-2410M @2.30Hz
8GB Ram
Windows 10
Intel HD Graphics 3000
Interface: using M-AUDIO M-TRACK 2x2 (That was successfully installed an recognized by the system)

Following the popular advice on the web I got into: “Control panel>System>Advanced system settings>Advanced tab>Startup and recovery>Settings” and changed the “Write debugging information” to “Small memory dump (256 KB)”.
But that didn’t change anything - it still crashes with the same error.

This error could be caused by many different things.

As a start I would try redownloading/reinstalling your Cubase software. Make sure the eLicenser software is the latest version. Also make sure you have the latest driver for your audio interface installed.

If these don’t help then I would try these procedures.

https://www.drivethelife.com/windows-10/fix-unexpected-kernel-mode-trap-on-windows-10.html

Good luck.

Regards :sunglasses:

It’s possible this has nothing do with Steinberg software. .

That laptop is pretty old, it might be a good idea to make sure you have the latest drivers from Dell, and also follow the advice in this page, which discusses ks.sys specifically:

http://www.tomshardware.com/faq/id-3128612/fix-windows-system-service-exception-sys-error.html

Solved!
At first I did everything:
I got rid of all security software and everything that could make conflicts, but it still crashed the same.
I did however try to use the old Cubase LE 5, that I still have on my computer and it worked fine. I did saw the minimum specs for PC’s on Steinbergs’ site and it seems that mine is ok. I checked even before, and I did have the latest drives for everything. Still it crashed.
Then I saw that there is an update from windows (I did make the April, or how do you call it, latest big update for win 10). I made the update, restarted, and then it worked. No idea why. It was just a small cumulative update.
Then I brought back my Avast antivirus and it continued to work. I have no idea what happened.

Maybe a Windows dll that had to match your current install. Anyway, great!