Error connecting to audio engine


I have Dorico 3 and every so often when I open a project the play button is grayed out and none of my music plays back. When I go to Device Setup to try and fix this, it says “Error connecting to audio engine,” and then sometimes if I leave the program open it stops responding after that. Restarting my computer usually fixes it but then it comes back a while later. I thought it might have something to do with Bluetooth because it ALWAYS happens when I start Dorico while connected to a Bluetooth speaker/headphones but it also sometimes happens without Bluetooth involved so idk.


For a start, please start Dorico and from its main menu choose ‘Help > Create Diagnostics Report’. The corresponding zip file attach here, please. I’ll have a look at the data and then come back with further advice. Thanks

I have the same problem. Today when I opened the program I started having problems with this. I cannot write any note… (I have been working with Dorico for 7 months and I didn’t have any problem before, but this one is really annoying…)
The play button is in grey and I have the message that says error connecting to audio engine.
Also when I try to close the program I can’t and I have to “Force Quit” the programm.

I send you the diagnostic report. I hope that there is a solution for this…

Thank you very much!

(I already tried to update the eLicenser but it doesn’t make any difference)
Dorico (290 KB)
Screenshot 2020-10-09 at 22.46.53.png

Welcome to the forum, mjartells. I’m very sorry to hear you’re having this problem. It certainly appears that the audio engine cannot start, which explains why Dorico can’t connect to it. Have there been any changes in the configuration of your computer recently that might give us a clue as to why things are no longer working? Have you rebooted your computer? Have you tried disconnecting any external audio devices you might have, and using the built-in audio device instead? Have you run the maintenance tasks in the eLicenser Control Center?

Before you start Dorico, please launch Activity Monitor and make sure that no VSTAudioEngine process is lingering around. If there is such process, highlight it and click the X icon at the top of the window to kill. Only then launch Dorico. Dorico will also launch a fresh instance of the VSTAudioEngine. Does it succeed then?

Also strange thing is, there are no crash files in the diagnostics report. Please launch the Console app and see if you can find user or system report in regards to the VSTAudioEngine. Thanks

I’ve been having all sorts of trouble with Dorico since installing 3.5.10. Sometimes the engine starts along with the hub, sometimes it doesn’t. Even if it does start, there’s now ALWAYS some problem with the audio engine when I load my score, with the result that I’ve completely lost the ability to hear my music. Most of the time, I can’t even go to Edit->Preferences->VST Plug-ins (if I get even that far) without Dorico totally hanging, and the Windows operating system eventually presenting me with the option forcibly to terminate the process.

Initially, I’d chalked it up to some kind of corruption in my score file, but I’m seeing precisely the same problems when I open other people’s scores. I did seek help for my problems a few weeks ago – Dorico’s staff are always a pleasure to communicate with, and I very much appreciate their availability and effectiveness at troubleshooting – but the proposed solution was to move my license over to my USB dongle, which is unacceptable.

I’m currently taking a break from using Dorico, until version 4 is out. Perhaps by then I’ll have the time and energy to deal with these problems, should they persist with the new software.

Hi Milo. I thought 3.5.11 had been out to correct some problems with Win, have you installed this one ?

Hi Daniel,

well, yes I have recently updated my macbook pro to Catalina. Do you think that this is related to the problem?
I tried to reboot the computer, to uninstall dorico and install again, but the problem remains. And I don’t have any external audio devices. And I also did the maintenance tasks in the eLicenser Control Center. Non of this things solved me the problem.

And Ulf, I also tried all what you said but the problem remains…
I also watched this video: to see if my problem was here but there is no solution for this problem here.

Thank you for your time, is there only solution that I should try?


Miquel, your problem is difficult to grasp, because - as I mentioned before - there are no crash dumps contained in the diagnostics you’ve sent. And the logs also don’t give any deeper insides of why the audio engine does come to a standstill. Is the problem easily reproducible on your machine? If so, then a remote screen sharing session could be helpful, where I coud see myself what is going on and how your system behaves. If you agree on this, send me a mail to ‘u dot stoermer at steinberg dot de’ and we’ll sort the details.

The problem with Miquel was that OSX terminated the audio engine due to a failed code signature check in Kontakt. He will check for an update version. In the meantime I modified his project to not use Kontakt for the moment.

I don’t think I was involved in this troubleshooting process, Milo, so I don’t know what was suggested, but I guess you explored trying Dorico 3.5.11, the Windows-only hotfix that changed some license initialisation (though only in Dorico itself, not in the audio engine), and you tried both eLCC version 6.12 (the new one included with 3.5.10/3.5.11) and the previous version 6.11 (which was included with 3.5 and earlier versions)? There are some reasonably significant differences between 6.11 and 6.12 in terms of their internals, so although 6.12 fixes some long-standing issues on both Windows and macOS, it’s not impossible that you might find 6.11 continues to work better on your system.

The fact that the eLicenser is preventing you from being able to use the software is unacceptable to me, and I will do whatever it takes to resolve the issue so that you can get up and running again.

Hello Marc, yes, I did install that. No help, although I didn’t think it would be; I’ve read elsewhere that it’s meant to address some other issue. (I was just sort of shooting in the dark by installing it.)

You mean, the eLicenser is somehow preventing the loading of the audio engine, or defeating Dorico’s attempts to connect to it? That’s weird. :confused:

Anyway, I responded to your private message to me. Thanks so much for your time!

Quick update, I went ahead and moved my license over to my USB dongle, as both Daniel and Ulf suggested. I’m not experiencing the audio engine problem anymore.

I don’t like using hardware licenses, but I’m fine with it as a temporary workaround. Hopefully, the issue with the accursed eLicenser will be resolved within the next couple of releases of Dorico.