Error exporting any files

I just installed Dorico 3 coming from Dorico 2 and now I get an error message when trying to export MIDI or audio files.
I’ve tried multiple times, restarting the computer, changing the file export location to no avail.

Solution?

Sorry to hear you’re having problems. What specific error message are you seeing? What operating system are you running? Do you get the same error message regardless of which project you try to export MIDI or audio from? Do you get the same error message if you try exporting to a different folder?

Can you do Help > Create Diagnostic Report, which creates a zip file called “Dorico Diagnostics.zip” on your desktop, and then attach that to a reply here? It will probably give us a clue as to what is going wrong.

OS: Windows 10
The message is slightly different for audio and MIDI: see photos.

I’m trying to attach a diagnostics report but it says the file is too large.


Dorico MIDI export error.PNG

There’s this: https://www.steinberg.net/forums/viewtopic.php?t=120356

and this: https://www.steinberg.net/forums/viewtopic.php?f=246&t=172702

or maybe this: https://www.steinberg.net/forums/viewtopic.php?f=246&t=169887&p=909324

You can email your diagnostic report to me at d dot spreadbury at steinberg dot de.

I think I have it figured out.

After opening the files from Dorico 2 it seems I have to save them in Dorico 3 first before anything can be exported. I’m guessing Dorico can’t create a file path for the older files for some reason. I am using “save as” and giving them a new name.

When you open a project from an earlier version of Dorico, it considers it is a “new project,” so that you don’t accidentally overwrite the old version by doing “save”. The first time you do a save, you get prompted for a file name (and of course you can then overwrite the old file if you want to).

So as a side effect of that, Dorico doesn’t “know” where to export files until you have saved the project somewhere.

I’m not sure that’s really quite right. Firstly, it’s optional whether or not Dorico should prompt you to save a project from an older version under a new name when you save it for the first time, and indeed that option is off by default. Plus you can easily export audio from a newly-created project that hasn’t yet been saved, so I don’t think that’s the explanation.