Error message when opening an audio montage: Load Library Failed with error 87 [SOLVED]

I tried to load an old Wavelab 6 montage which resulted in an error message stating 'Load Library Failed with error 87: The parameter is incorrect. Since then I cannot cannot open any new audio montages, even a new template, as the same error message appears and then Wavelab crashes. Has this happened to anyone? If so can you let me know how can I get rid of this issue - I’m reluctant to reinstall the software as I’ll need to update all the parameter again. Many thanks

This is not a WaveLab message per see, but a Windows message. Probably, the problem is not caused by the old WaveLab 6 montage but by something else.
Try erasing the preferences:
\AppData\Roaming\Steinberg\WaveLab Pro 11\

Hi Thanks for getting back to me. I have tried that, and deleted the WaveLab Pro 11 file in AppData/Roaming/Steinberg/WaveLab Pro 11. When I open Wavelab it does not show the error message on opening (which it used to do - which is good) but whenever I select open a new montage (either custom or template) or from an old wavelab 6 file - the same message occurs, wavelab freezes and when I click OK (see attached picture) wavelab shuts down.
Error Message
Do you know what else it might be or should I just re-install having saved my preferences? I have only recently updated to pro 11, so much is unfamiliar. Many thanks Vince

It’s not a file but the whole folder you have to erase. Did you do this?

Yes sorry I deleted the whole file called Wavelab Pro 11, a new one appears when I load wavelab and have deleted those too.

The folder will always be recreated, this is normal.
Try this search:

Ok I’ll try that, many thanks, will let you know if that solves the issue. Cheers Vince

The drivers for the Display adaptors are now up to date, and I deleted the wavelab pro 11 file again (as it initially brought up the same error message) and it did open a template montage, but now it keeps bring up the same error message. I have also noticed there is a smtg-frame_64 file in the steinberg Roaming file (of todays date). Should I delete that too? I am using a usb hub for the two monitors I use and I have a third monitor plugged in via the RGB connector. Might that be the issue? Cheers Vince

Strange. What is the exact path of this file?

The file path is the same as the WavelabPro11 I’ve been deleting;

This is a folder, not a file. The presence of this folder is not a problem.

Concerning your problem, I recommend uninstalling WaveLab, then to install again.
But since the problem “87” is a Windows conflict, I am not sure this can help.

I contact some Windows support and they managed to fix the issue, not sure of the technical details, or what the issue was caused by, but this is the details of the installation that cured the issue:
Windows Installer installed the product. Product Name: ScreenConnect Client (4cb87afacc0e257c). Product Version: 19.4.25699.7240. Product Language: 1033. Manufacturer: ScreenConnect Software. Installation success or error status: 0.

Thankfully, the error message no longer appears. Thought I’d share for anyone else with this issue. Many thanks for your support. Vince

1 Like