Error notification

I have installed Dorico on a new laptop and I keep getting an error message - "no such file or directory Error creating zip file: C:/Users - etc.

How do I resolve this?

Did you perhaps copy the user preferences folder from another computer in order to transfer custom keyboard shortcuts etc?

If so, the preferences.xml file in there contains the AutoSave path. If your username on the new computer is even slightly different to that on the old computer you’ll need to either manually edit the AutoSave path so that it contains the correct username, or delete preferences.xml; this will set various application preferences back to factory default.

Wow, Leo, I’m very impressed!!! I did, in fact, copy the user preferences from my desktop. So I will try to edit the path.

Hi Leo, How do I get to AutoSave path in Dorico to edit it?

No. AutoSave saves at regular intervals (and this is set within Dorico Preferences), whereas the Backups folder keeps a copy every time you manually save.

Inside of Dorico I have altered the AutoSave folder to the one I want it to save to and I still get the error message. I the back of my screen shot, I opened up the XML file, but I am unable to edit it. What am I doing wrong? Help Leo!!!


As I explained above, it’s the AutoSave path that needs correcting in the preferences.xml file.
I’ve also explained that the AutoSave folder is not the same thing as the Backups folder. Fixing one will not fix the other.

Your screenshot shows that your username on this computer is sttru. Any instances of the username Stan need to be replaced with sttru in the preferences.xml file.

Yes, I understand what you are saying. The file that I have in the back is the XML file that I cannot alter. I double click & right click, but I can’t seem to erase “Stan” and replace with “sttru”.

I’m not sure what’s required to edit XML files on Windows - it may be that permissions need fiddling with or something. Hopefully someone with a Windows machine can jump in and tell you what you need to do in order to make that change.

Hi @sttrumpet, by double clicking you open the XML file in the browser, but that one can only display but not edit it. Instead you need to open the xml file with an editor program; the most simple one e.g. is Notepad. So right click the xml file and choose Open with… and then pick Notepad or whatever other text editor you might have. Be careful though not to change the formatting. Therefore it might be even a good idea to make a backup copy before editing.

I ended up downloading a program called Notepad ++ . Downloaded a plug in “XML tools” loaded the XML file and now I’m good!!! Thanks for your help, Leo!!