Eucon 3.0 keeps crashing my PC

This is a vicious cycle. I launch N6.0.6, then I load my project, then I turn on the controller. 7 out of 10 times I’ll just start working on my project. But the other 3 times sets off a catostrphic chain of events.

In this chain, I launch N6.0.6, then I load my project, then I turn on the controller. The controller has dropped it’s connection with Nuendo. So I close Nuendo and go check the Eucontrol to see what’s going on. The first couple of times, I would add HUI protocol. I’m not using it. I just want to “wake Eucontrol up.” The goal is just to make the apply button activate, which means that I’ve awakedned Eucontrol. Sometimes I cancel, other times I might hit apply and go to close Eucontrol. When I hit close, I get the “blue screen of death!” :open_mouth: I run down the hall to the machine room to physically turn the PC off. I reboot the PC.

When I get back into the studio, the PC is booting and asks if I want to start windows normally. I say yes, as its the ONLY option offered. It reboots and my desktop comes up, IF I’M LUCKY. If I’m not, my desktop comes up with all of my icons scrambled and one of my monitors has switched to the lowest resoution possible. Now I’ll lose another 8 - 10 minutes getting my screen resolution back and putting all of my icons back in their “normal” positions.

Then I start Nuendo. Then I open my project. Now the project stalls on opening because the crash ALWAYS drops the connection with my VSL dongle and thus claims I have no license for the VSTi’s. I go back to the machine room and reset the dongle. I tell it to try again and the project opens. Then I turn on the MC Control and, with the connection restored, it works like it’s supposed to. Total loss of time? 6 to 10 minutes, if the desktop “holds” and 20 to 30 minutes if it doesn’t!

So the obvious question is:

  1. Why is Eucontrol dropping the connection?
  2. Why on earth does it make my PC crash when it does drop the connection?
    3) How can I get it to STOP doing this?!!?

BSOD usually shows there is a driver or hardware issue involved. It should not BSOD so I would be looking to figure out what’s wrong with your machine first.

It never happened before Eucontrol. So, where should I be looking?

EuControl might be pushing something to its limit. If you have crash logs you can use the Microsoft crash dump analysis tools to see where the crash originated from which might give you some clues as to what is causing it.

I’ve been using Eucon for a while now and here’s my way of working:

boot computer.

When I get to desktop, switch on each Euphonix device one at a time with a pause between each one.

When they’re all up and running, you can see by the display;

Open Cubase/Nuendo

This method has worked for me without any issues now for a couple of years.


make sure you got Eucon 3.1.2 it is much more stable than previous versions.

I sure hope so, because, right now I can’t even uninstall 3.0!! :astonished: The MC Control dropped the link again this morning. Fed up with this BS, I decided to just uninstall Eucontrol and star again from scratch. When the prompt came up to remove all associated programs and parameters of Eucontrol, I selected yes. 10 seconds in, I got a BSOD crash!!!

So the next time I tried to reboot in safe mode. But the PC hung up altogether. So, now I’ve got to run the startup repair sequence. That led to having to do a system restore. Once all that was done, the next attempt to uninstall Eucontrol delivered the same BSOD crash! So now, it looks like my only recourse will be to install 3.1.2 over it and pray that it REPAIRS Eucontrol in the process! What a pain!

I just tried to install 3.1.2. I got BSOD crash, WTF?!!?

Well, I’ve apparently got some kind of driver hanging up the system. So I just did a cleaning with cc cleaner and now I’m running scans to see if I picked up some kind of virus or malware script. I’ll get back to you later.

5 hours later, numerous scans, cc cleaner to get Eucontrol OUT of the PC, and several restarts later, I have finally replaced Eucon 3.0 with 3.1.2 (Whew!). I hope to GOD that this will finally solve the problem and stop all this drama!