EuCon 3.2.1 doesn't work


I recently updated my EuCon Software to 3.2.1. When i start Cubase 7.5.3, it tells me that “no valid EuCon software can be found on the system”. Do i have to wait for an update? right now i’ll go back to an earlier version…

Cheers, Thomas

3.2 is working for me and is the first release in a long time to actually improve overall experience in terms of stability and reliability. I would try a complete uninstall/re-install.

+1, all working fine here too. I was dreading it, had been on 2.7.1 for ages very happily and heard all the EuCon 3 horror stories, but had to upgrade with PT11. Everything worked perfectly first time (win 7 64bit, Cubase 7.5.2), so a reinstall of the EuCon package seems like the place to start.


I still have no luck with EuCon 3.2.1. Cubase 7.5.3 did’t found the EuCon application. On the Artist Mix homepage it says that EuCon is only 64 Bit. But that’s only for the operation system? I’m still on Cubase 7.5.3 32 Bit…did someone encounter the same problem with Cubase on 32 bit?

Cheers, Tomess

Yes I have the same problem. cubase 7.5.3 on a windows machine with the protools dock. and I have tried several euCon software.
but Always the same; no valid eucon software can’t be foundon the system.