EUCON Despair

Hi, I use Cubase 8.0.20 and the latest Eucon Software Version.

The Connection only establishes when I Switch on my mcmix and my mccontrol upon Windows start. Then the first start of Cubase also works fine. As soon as I quit cubase and start it again, the Screen on the mccontrol says “cubase8” but no control is possible (even though the right Buttons/touchbuttons appear on the Screen!).

When I start the Eucon application one Thing sticks out: IT says “cubase8 on” and no longer “cubase8 on Studio” (my Workstation Name).

ANyone? I am really desperate.


What happens when you right-click on EUControl in the system tray and select ‘Restart Eucon Applications’?

Hi you, many thanks that you care for my question at all! :slight_smile:

Well, when I “restart eucon applications” the only Thing that changes is, that the eucon app not even is any longer Aware of the Workstation it is connected to (or was).

I am wondering what is going wrong. I even tried uninstall and reinstall with the latest Eucon Software release. The first Thing that happened then was (upon system start) that an error message “ExHUI could not be found” appeared.
The rest of the behaviour did not Change.



Hi, i have to add - our Systems are very similar. I have an asus X99-S Motherboard, but I run win7 ultimate 64bit.

Cheers, Ernst

Are your Artist devices attached via a dedicated router? Are they set to use static IPs?

Hi you,

my Artist devices go to a small Switch that is connected to the router. The pc is connected to the router as well.
The IPs are not static, but they are reserved in the router so that the Artist devices always get the same ip-adresses.
I checked whether they are linked correctly to the router (logically and physically) and yes, they are. More than that: The Eucon Application recognises their presence! The “Connection” Thing is selective for cubase.

Thx Ernst

I see… So the Eucon application is working properly but Cubase is not seeing the controllers the second time Cubase is loaded?

yes, exactly. The Screens on the McControl Change to “cubase” but no way to control anything.

I wonder if its worth trying re-installing the latest version of Steinberg’s Eucon component. I think it was included in the original v8 distro…

Hi you,

yes, I happen to be in a Situation to do a fresh install of everything. I will take the Chance to start “from scratch” and see what happens!

I’ll Keep you informed.


Thanks… Please do… Good luck with the fresh install


Hi, I have now reinstalled everything and done a lot of work.

My finding so far is that EUCON never connects to cubase reliably when ANY Firewall ist active and/or installed.

Deactivating the Windows Firewall.
I use the G Data Internet security. Whatever rules I established so far - the Connection is “random”. Even disabling the g data Firewall does not work.

The “solution”: I installed the gdata with the Virus scan ONLY. (No Firewall).

Now it seems to work.

Still I would be interrested whether this is a General issue.

CHeers, Ernst