Eucon issues with 8.020

After the 8.020 update my McMixs doesn’t have vu’s on some tracks…

And I suspect I’ve some crashes because of it…

Someone had this?

Well,… I upgraded to 8.0.20 from an old 6.5 version. Then I installed Eucon 3.2.2 and operated an Avid S3 surface. Was pleasantly surprised to see how well the S3 worked with Cubase, except the LED vu meters did not work for mono channels, but they did work for stereo channels. Was assuming it was a S3 hardware problem, but now wondering about 8.0.20.
Can you recommend an older version that worked for you before 8.0.20?

I posted here yesterday, but since I just registered, the post is awaiting moderation.

Following your clue, I installed Cubase 8.0 and found the vu meters worked fine on an Avid S3 controller, while other S3 functions were inoperative. Cubase 8.0.20 fixes the inoperative features, but disables the mono channel vu meters.

Yes, the Cubase 8.0.20 update does impact vu meter operation in Eucon 3.2.2.

And also… Cubase 8.0.20 requires that you use EuControl 3.2.2 or later, so no going back to an earlier more functional version of EuControl! :smiling_imp:



I researched the history of the Avid S3 before buying it, although the info was in relation to Pro Tools. Up until March 2015, it was a disaster, but finally a lot of perplexing problems were fixed with Eucon 3.2.2. It is my opinion that Eucon 3.2.2 itself is useful and stable (I also use it with Media Composer without issue).

Ultimately, our experience comes from the coordination of code from both Steinberg and Avid, which makes resolving bugs so much more difficult. Oddly enough, a Steinberg rep told me that originally EuCon was jointly developed by Steinberg and Euphonics. I use the S3 with Cubase and Avid media composer. Cubase supports the S3 way beyond my expectations, perhaps just as well as Pro Tools. Media Composer support for the S3 is no more than a ported Artist Mix, and nothing else.

I think Steinberg has a little more work to do with EuCon, as well as Windows 10, but their potential certainly rivals that of Avid.

Yea… my observation has more to do with functionality, and also as it pertains to the Artist Mix! The later updates of EuControl has removed or just plain broken the Shift + Touch = 0dB function on the “Mix”!

I also have an Artist Control where that particular function works fine!

The S3 is pretty new compared to the Artist Series controllers, though they seem related… So, my EuControl history goes back a little further, and I have had the opportunity to test many iterations of EuControl with Cubase 6.5, thru Cubase Pro 8, and the best fit for me was EuControl version 3.0.1, with Cubase Pro 8.0.10!

Now… with Steinberg requiring what I consider a more limited/broken EuControl version 3.2.2, I feel like I’m being urged to walk the plank! :smiling_imp:



Yes, we live in interesting times. Ultimately, we depend on the coordination of software from two different companies, and as one thing is fixed or improved, something else is broken.

I appreciate your experience, as it helps us all navigate the minefield of bugs and release variations. Now, I’m off to find a copy of the 8.0.10 update (which I didn’t know existed before), and see how that works with the S3.


working fine here. did you do a firmware update as well? I had to do soft and firmware update when I updated to the latest Cubase version.



Same strange issue with Artist Mix and Touch+Fader=0dB.
As well I’m enforced to start the EuControl separately after the startup of W7, because EuCon v 3.2.2 does not link to the startup as it was with v 2.7.1.

Finally, both devices are working well and I’m still a fan of the endless flexibility in adapting the working process to this midi controllers.


And with 8.030 stays the same issue with mono tracks… :frowning:

Should try the Eucon 3.3 release, which fixed my mono track problems on the S3.