Eucon Jog Position

Hello all,

I can’t seem to get Jog Position to work anymore in Cubase 7.0.1 with my MC Transport. It initially wasn’t working, I messed around a bit resetting commands in the EuControl Settings, it started working, and now upon relaunching Cubase, it isn’t working again. I’m sure it’s because I didn’t save my changes in EuControl Settings before quitting Cubase, but I can’t for the life of me figure out what I did to get it to work in the first place.

Any help is appreciated.


Well 7.0.1 fixed the issue for me, but try re programming the button in EuControl.
TU Softkey
Type = Wheel
Function = Left Edit Jog

Jogging works fine for me. It’s just Jog Position that is no longer working. I frequently use Jog Position to quickly get around my projects.

Have you tried to re program with Jog Position?

Edit: I just tried Jog Postition and it is working here.

Sorry for the late reply: I haven’t had a chance to work in Cubase since my last post. After the break (and at least one system reboot), my Jog Position is working properly. Thanks for the input and sorry for the confusion. When in doubt, “turn it off and on again”.


Ack! Jog Position isn’t working again! I swear nothing has changed. I thought it might have been because I was flipping back and forth between Cubase 7.0.1 and Pro Tools 10.3.3, but after a fresh reboot and only launching Cubase, Jog Position isn’t working again.

I looked into making my own Jog Position custom command, but I can only find EuCon controls for Jog Right/Left which isn’t the same as jog position…

Another update. The broken Jog Position seems to be related to a particular project I’m working on. I created a new project and Jog Position works properly. Here’s to hoping that 7.0.2 fixes the EuCon weirdness.

If anyone has any other suggestions, I’m all ears.

Quick question for all you EuCon users out there, in Device Setup, what version does your EuCon device say it is? Mine is saying which seems like maybe I have the wrong EuCon adapter for Cubase 7.x?

Eureka! I found the issue. EuCon Jog Position in Cubase 7 is affected by Snap settings. I tend to use Magnetic Cursor a lot, and Jog Position will not work when snap is on with Magnetic Cursor as the cursor tries to snap to itself. Snap off = working EuCon Jog Position.

FTW, this is not how Jog Position worked in Cubase 6.x and 6.5.x. I can easily work around the limitation, but it’d be nice to see the bug fixed.