Eucon Project settings - Cubase 11

Studio Setup -> EuCon settings - cannot change and save settings. You cannot change the settings of active EuConized channel types.

Hi,

Sorry, I have no EuCon connected here. What does prevent you from changing it, please?

you cannot change the setting of which channel type I want to have active (MIDI, Audio, Group, Output, etc.) The same selection is still set and cannot be changed. The “Apply” button is inactive. The changes are not saved even after pressing the OK button. Everything works in Cubase 10.5.

i have the same issue. I upgraded from 10.5 to 11. The Eucon settings remain set to the 10.5 settings and cannot be changed. The ‘apply’ button is greyed out.

Hi,

Thank you, reported to Steinberg.

Not going to use Cubase Pro 11 and my Avid S3 until Eucon is properly supported and I can also render in real-time my external instruments.

1 Like

It will not EVER be supported. I just got this from Steiny:

Hello Michael,

We no longer support Eucon hardware. Please reach out to Avid for further support.

Thanks,

Steinberg US Support

butch - Steinberg support are famous for not really know what is going on.

it’s true they can’t support the “hardware” - but eucon is supported…although still buggy !

Timo from Steinberg has announced on the Nuendo 11 thread that Steinberg intend to properly sort Eucon out in a Nuendo 11.x release early next year.
If that happens (there’s been a lot of pressure from Nuendo customers) then it should make it into Cubase as well.
However this probably means that nothing will happen in the meantime…

Hi,

This is simply not true. The EuCon component is still in the development in Steinberg.

+1 on the grayed out apply button and working in 10.5.

I made sure I had the latest EuCon downloaded from Avid too 2020.11.0.187.

I am seeing in the Studio Setup dialog that the EuCon version is 7.3.0.6 Jan 16 2020 in Cubase 11 and is the same on used in 10.5.20. Guess I’ll just wait for the fix.

W

+1 here - the apply button is greyed out in 11 but all working fine in 10.5. Very irritating especially given that ‘Eucon Support’ is touted as one of the ‘New in 11’ features and was one of the things that encouraged me to upgrade…

Please fix ASAP!

+1 here too! Major problem in 11 exactly as described and really leaves my two artist mix pretty much useless - hope this gets fixed very soon!