Eucon with Instrument Tracks. MIDI inserts window should not open when editing audio inserts/plugins.

I don’t know why this occurs but it’s extremely annoying when trying to do a mix using Eucon control surfaces in Cubase. I didn’t have this problem on my old Mackie Control mixer so it is a Eucon only thing.

In the Arrange Window

Quick troubleshooting example:

  1. Create an instrument track
  2. Avid Artist Mix: press EQ button
  3. Cubase EQ menu opens up
  4. Avid Artist Mix: Press inserts
  5. Midi inserts opens up instead of audio inserts.

Do the same on an audio track and audio inserts open. Yet in both cases, should you have audio inserts present, audio inserts will display on the control surface. Suggestion: Audio Insert menu should open on both audio tracks and instrument tracks. You can’t edit midi inserts on the Avid Artist Mix or would you want to, so there is no reason the MIDI inserts window should open.

Longer trouble shooting:

  1. Add an instrument track
  2. Avid Artist Mixer: Press the Channel button
  3. Avid Artist Mixer: Press the inserts button
  4. In the arrange window, MIDI inserts menu opens.
  5. To add an audio insert with the mouse, you must click on the audio inserts menu to close the midi inserts menu.
  6. Add audio inserts with the mouse
  7. Avid Artist Mix: Press the EQ button. EQ window opens.
  8. Press the insert button, MIDI inserts open. Yet previously added audio inserts display on the control surface
  9. To add another audio insert, you must first click on the audio insert menu with the mouse.

There is a setting in Eu Control called “eucon Workstation Tracks Knob Set Changes”. If you untick this, it won’t open any menus so although it stops the midi inserts menu being opened by mistake, it also stops the all the other menus from being opened such as the EQ and the inserts menu on audio tracks. This setting is obviously where the problem is. For some reason the inserts button is set to open midi inserts instead of audio inserts. Considering that people use control surfaces for mixing, not for editing midi parameters, it should be changed to audio inserts. I suspect the issue is just a bug based on the fact that instrument tracks didn’t exist at the time Eucon was made and it’s confusing an instrument track with a midi track when it should be acting like an audio track.

When mixing a song with instrument tracks, having to close the midi inserts all the time which keep opening by error and then having to manually open the audio inserts with the mouse is an annoying workflow issue.