EWQL Symphonic Orchestra & Choir: SOLVED

I’m using Cubase 7.05 EWQL Symphonic Orchestra Platinum Plus and Symphonic Choirs all 64Bit.

When I try to load Play I get the error message that the plugin is not compatible with this version of play. p[lease download the latest update.

Product Plugin symphonicchoirs
Play Version 1.2.0
Minimum required 1.1.17
Your version 3.04.47.

So does that mean I either can’t use choirs, as I need an older version of play to make it compatible or to use choirs I’ll have to lose the ability to use platinum orchestra?

It took me nearly a day to install all 34 Dual layered DVD so I’d really like to get them both to work,

Ian: what brought you to the conclusion that you need an OLDER version of play? :laughing: Yours is the oldest version I ever read of. They are now at 3.xxx and installing the newest version should solve your problem. Just downloadable at EW. Probably your version wasn´t even 64 bit compatible.

If you read carefully, the OP says “Your version 3.04.47”, which is supposedly the most recent public release of PLAY 3. I think the 1.2.0 refers to the Choirs version.


Symphonic Choirs should not require any additional plug-ins to work in PLAY. Actually, the library’s patches should load and work like any other PLAY product since the wordbuilder MIDI modifier is built-in now.

How are you trying to load Choirs? (post a pic if you can)

Thanks for the reply guys. EW support got back to me and the fix was a complex series of removing east west folders (data for example) uninstalling Play and then reinstalling. All works now apart from getting an error message when I load a choir instrument that then plays fine!
Now how to learn to use this software! It’s gonna be a long learning process!