Export double bass midi from Dorico to Cubase, wrong octave


When exporting a double bass midi track to Cubase, the imported file in Cubase plays back one octave too low. This could be caused by the reason that a double bass is a transposing instrument. It sounds one octave below the written notation in F-key.

There is an easy way to solve this in the HSO instruments settings, play back +1 octave. BUT then also the expression range is shifted. Result, my lower F is not played anymore because this is the trigger for ‘Espressivo’.

What is your experience? How do you solve this?

1 Like

I’m not sure why one would want to “solve” this. The DB is supposed to sound an octave lower than written. That it does so in Dorico and in Cubase seems to be what one should expect.

Hi Derrek, that is exactly the point, either Dorico either Cubase is not doing it right. It sounds well in Dorico, after importing in Cubase, it sounds 1 octave too low.

You need to transpose the notes in Dorico from the score before export, I think. This way the keyswitches are not also transposed. Doing the transposition in Cubase is harder because of course it doesn’t distinguish between real notes and keyswitches. I’ve had exactly the same issue with piccolo and double bass in particular.

Thanks David, glad to hear I’m not the only one noticing this issue. What you’ve suggested is indeed a useful workaround.

But is still an issue that not should occur, especially between 2 software packages of the same company. A possible explanation could be:

  • Dorico writes the notes in the midi file as they sound (e.g. a written C3 becomes a C2)
  • Cubase interpretes the midi file as written - not as sounding - and therefore transposes an extra octave down (e.g. the above C2 then becomes a C1).
    I did a quick research on google, but not find a specifiation on midi files whether they contain correct sounding notes whether transpositions. I assume that midi would use the sounding pitch to keep things simple.

I think we agree that there is a valid point here. I also don’t know whether MIDI interprets the notes as written or as sounding but assume the former – which is why the issue arises.

Dorico will always export the notes in MIDI files exactly as they are played. If they are transposed by an octave by the Transpose setting in a switch in the expression map, for example, then that transposition will indeed be reflected in the exported MIDI file.