export midi file, just one track?

Does anyone know if there is a way export a single midi track as a midi file?

When I use the export as midi file under the file menu it seems to export every single track?

I used to use this all the time to export presets for my hardware synths.

please help.

thanks,

Make sure you set the locator points and solo the relevant track - that should do it.

I know it’s a big pity that Cubase hasn’t got a function: “Export Selection as MIDI”.

Here’s a work around :

Go to Key Commands and create a New Macro: F8 -> Show Macros -> New Macro

Macro Commands(assumes you have selected the midi regions you want to export):

Edit-Invert Selection
Edit-Mute Events
File-Export Midi File

Then once you have saved
Just do Ctrl-Z )or Cmd-Z on mac) to make all tracks go back to their previous muted/unmuted state.

Hope this helped,

Solo the MIDI track before exporting.

I figured this one out.
you just solo the track and it exports only the one track.
even if you set locators the midi file includes the empty bars in front of the event.
It also includes the offset bars so I guess I will have to go back to starting my cues on bar 2 like I used to in Logic.
I was hoping the bar offset in the project setup would compensate automatically but if you do not start on bar one then your midi file will not have the correct bar count in it.
Another snafu is the fact that it saves the file with a .midi suffix instead of the .mid suffix which you can make by either typing in the suffix yourself (because there’s not enough to do) or you can change it in the finder after export.
not sure what the point of the .midi extension is.
Sibelius and Finale no likey…

I know you can do better Steinberg.

Not if you set it up correctly.

how do I set it up correctly? What does this mean.
I am looking for guidance here.
If ou have some to offer I would appreciate it.
thanks,

Sounded more like you were looking to complain about something that is your fault… -Take a closer look at the MIDI export options…
Also MIDI files get exported with the suffix “.mid" not ".midi” here, so once again you might want to look for a fault in your system.

to export single midi track:

Just drag the track to desktop! That it.
You will get that track as a .mid file

DO not use the export function or you get .midi file and protools will not see it.

god i spent half an hour trying to figure out how to export just the selected midi event
thx

there should be an option in the shift+right click menu

I know this question was 5 years ago, but if someone is looking for an answer to this:

Just drag from the cubase arrange and drop it in a folder on your computer


and for load midi, you can do the same, drag from your folder to your project arrange

Brilliant! Simple and brilliant! Many thanks!!

Brilliant! Simple and brilliant! Many thanks!!