Export midi to use in superior drummer/ezdrummer


I am trying to export my own programmed midi (that play nice in superior drummer through the daw), so that I can use it in say standalone superior drummer.
What am I doing wrong?

I have gotten it to play some of the midi. But the loop starts half way in, and it is playing a different part that i exported…

What I have tried is to:

  • cut out the midi part I want. Set locators to that part. Export midi file, between locators (both type 0 and not, I don’t know what type 0 does or mean…)
  • Cut out the midi part I want. Merge MIDI in loop. And export midi file again.
  • Cut out the midi part I want. Copy that part to a new midi track. Merge MIDI in loop. And export again.

Any MIDI gurus in here that can tell me what I am doing wrong? :slight_smile:



If I’m right, MIDI export is not based on Locators. Cubase always exports the whole song.

Martin is wrong - there is an option in the Export Options dialog which pops up (after you choose a location to save your file) where you can specify to ‘Export Locator Range’. BUT, I haven’t verified that this actually works… :slight_smile:

Its a puzzling problem - all what you’ve tried should work to my mind; the only thing I can suggest is you make sure you select (and solo) the track(s) you wish to export, first. That works for me (though as I hinted above, I normally only deal in whole length tracks - not parts of them). Good luck.!



I’m sorry… And thanks for the clarification.

Have you tried just dragging the midi part from project window onto desktop?

Midi type 1 files have separate tracks for each part while type 0 merge all tracks into a single track, sort of like a mixdown.

  • SMF 0 has all MIDI channels in one track.
  • SMF 1 has every single MIDI channel on its own track.

Yes, I have tried to drag the midi right to my desktop also. I also tried to export he whole track. And import it back to CUBASE, and even that didn’t work… There is something really wierd with my exports of midi… I have looked in prefs to see if I could spot anything off in there, but I don’t really know what I should look for so it’s like the needle in the haystack…
So if any of you know of something to be aware of in the midi prefs of cubase, let me know :slight_smile:

But thx for the clarification of SMF 0 and SMF 1 :smiley:

One more thing… What does resolution mean in the export menu of midi?

Yeah, that’s what I said Martin.

I’m sorry, you didn’t. First of all, you mixed up “Tracks”, “Channels” and “Parts”. For the explanation of SMF0/1, this is critical to be clear. And it’s not true, that SMF1 files have separated tracks for each part. If multiple Parts sharing the same MIDI Channel, they will be on the same track after the export with SMF1.

Btw, SMF0 is here just for backward compatibility. Some (very) old MIDI Devices can read SMF0 only.

I figured it out, in a way…

What I needed to do was:

Put every midi part on separate tracks, and the new track have to be a instrument track.
And every part has to be dragged to the absolut start of the project.
Put the track you want to export in solo…

The option, export between locators workes, BUT, I have to extend the right locator twice the distance of what the clip actually is. So what I did was, duplicate the clip, set locators between both clips, delete the second clip and export.
I find this very strange, but if I don’t do this cubase will only export half the clip…
(If i didn’t choose, “between locators”, the part would go on forever…)

This is the only way I have made it work with superior drummer. It may be that superior drummer is the problem, I don’t know.

Have you asked this in the Toontrack forum?

It seems I read this same question there and even confirmed that it did work. This was using Cubase. And the procedure wasn’t quite as convoluted as your discovery. I’m pretty sure it was even before Cubase Instrument tracks even existed, so I believe there is another simpler way. But it was a long time ago.

Good luck!