export mixdown issue

hello for few weeks now having this problem cant figure out, when i export mixdown if i export from begining of song exports ok, but if i export some bars in the middle somewhere instead of exporting like i hear it when i play from the start of the loop in the project, the exported files’ timing is messed up, kinna like it exports alittle off from the start of the loop so midi gets all messed up, any ideas? thanks

When I record a single long MIDI note and use a plugin to make a melody out of that single note, I get a lot of problems if I play the song from the middle of that long note. Seems like the plugin dont quite know when to start the sequence, so it sounds out of time.

Hi alonch1

have you tried increasing your audio buffer size (e.g. to 1024 samples)?

or could it be to do with the midi settings in Preferences? … under Preferences/MIDI, there is an option for ‘Reset on Stop’

If you are using Rewire (for instance with Reason), there’s other explanations and possibilities for the error!

thnks for the replys
the (buffer/reset on stop) didnt fix but did somemore testing and it seems its kinna like what sparstudio was describing. k this is only affecting the midi and if the midi on a track is perfectly on grid at the start of the loop it will export sounding fine but if theres a note right before the loop that continues into the start of the loop when mixd’down it will sound out of time. Is this normal? i think i remember it always mixing down exactly how it would sound when i press play at start of the loop in the project regardless of how midi situated?