Export Naming Bug on longer file names?

So this is something I’ve noticed happening on various versions of Cubase over the years. Not a biggie but can be annoying. As I’m mostly working on film cues some of my exports tend to have long filenames. An example of something I’m exporting right now:

PC 2m05 Finger Problem V2 200220 TC.

Pretty standard - Here we have project name, cue name, version number, date & a timecode reference. I always do broadcast wavs with embedded TC hbut find it a good idea to include the TC in the filename anyway in case something goes awry. So that’s all fine, but whenever I click to choose the File Path to save to in Audio mixdown it always drops the last 2 digits (3 technically including the fullstop), so in this case I’m left with:

PC 2m05 Finger Problem V2 200220 TC.02.21.56

I need to then manually re-enter the last 2 digits in the file name. If you’re not paying attention and you’re against a deadline this can catch you unawares and you’ll be left with an incomplete filename (embedded TC will of course be correct). Like i said not huge and can be corrected manually but it’s annoying enough. This happens with both stereo mixdown and multiple track exports. Does this have something to do with using certain keyboard characters like a fullstop perhaps? Basically this has been happening for as long as I can remember. Can anyone else test on their end?



Do you write the full name like this to the File Name path or do you use Naming Scheme?

I cannot reproduce it here on Mac.

Just a guess… Isn’t it actually a Windows issue? Could you try to name the file just like aa.bb.cc? I’m just wondering, if Windows doesn’t remove the string after the last dot thinking, this is the file extension. Just an idea…

Hi Martin, this is writing the full name path, not using the naming scheme.!i can enter it fine in the Audio mixdown duslogue but as soon as I choose a new fil path and am taken to the windows pop up the latter digits are dropped. It’s not just the last two but everything after a certain amount of characters.

Yeah I will try some other things except for dots in the TC reference. Maybe it won’t happen with different characters.

So this is appears to be an issue with using full stops. Just inputting anything with multiple fullstops and it will drop whatever characters are after the last full stop. Doesnt happen when using hyphens etc. Will just stop using fullstops I guess!


I have tried exactly the same name you entered. It worked as expected here (also on Windows), the whole name has been exported.

Yeah the file name is exporting correctly in the end. But if you enter it first in the name box in audio export window, then choose your file path it is truncated in the explorer window. Once re-entered it is back to normal and exports as it should. This is happening for me whenever I have a full stop invite file and, regardless of length.


I see, know I understand the repro. But unfortunately I can’t still reproduce it here on both Windows and Mac.