EXPORT: Selected folder doesn't exist


Ideas why this is happening?
I’m exporting into the project’s mixdown folder which is clearly there.
This also happens when I choose a specific folder I created.

The only option available is “export to project’s audio folder” but this creates a major blocker where, if I want to re-export the same file it prompts me if I want to overwrite the files, I click Yes but then it says “a file with the same name already exists in the pool, please choose another name” :expressionless:

I believe I’ve seen this before when the drive is set to read only. Choose your desktop as a destination and see if that works.


Thanks Wheel!
now my question would be:
how can an SSD be on read only if that’s where all my projects are written and saved?

I’ll be searching but I’m wondering if you have a solution? I’m on OSX btw.

Thanks again bud!

1 Like

also, Nuendo actually allows me to save the file in the mentioned disk but only in the Audio Folder of the project. Not anywhere else.
The plot thickens :rofl:

In my case it was an external drive on a Mac and I didn’t have permission to change it.

Thanks for the heads up.

Again this is something related to Nuendo’s architecture since I’ve never had any issue like this while using the same setup, same drive with Logic.

Wheels what’s the best, most efficient way to flag these things to the Steinberg team?

This doesn’t necessarily have to be related to Nuendo. I’m on Windows now. If you create a folder outside of Nuendo with admin rights, Nuendo cannot write anything there because it only runs with lower user rights. The folders created by Nuendo are of course writable. But I have no idea how it is on OSX.
I would take a look at the user rights of the folder.

1 Like

Thanks for your input TH,

my game dev, debugger mindset has been triggered by this particular thing and want to find out where is the culprit in the signal flow :rofl:

So far, the inconsistency with the “admin” aspect is that:

  • Nuendo doesn’t allow me to use the Mixdown folder of this project for admin reasons
  • Nuendo doesn’t allow me to choose any other location in the project (nor the entire SSD - just tested now)
    but at the same time
  • Nuendo DOES allow me to save the project on the same SSD
  • Nuendo DOES allow me to export in the Audio folder of this project on the same SSD

afaik, if an external drive is “read only” well, then you can read only and the fact that

  • some parts can ben written in the same SSD (Project and Audio folder within the project)
  • some others cannot be written (Choose… + Mixdown folder within the project)

This is what makes me think that’s related to Nuendo and that there’s an inconsistency in the code and it’s not user based.

But here’s a twist:

  • I just tried the Choose… option from the same project and exported a file into all my external HDs and it works all the time.

  • all my other HDs have been formatted into all possible file formats (MacOS Journaled, ExFat etc…)
    apart from one

  • the SSD I use for this project is formatted in APFS for security reasons.
    The game I’m working on is a huge franchise and I had to sign an NDA where it’s mandatory to store all the work into a password protected APFS encrypted SSD.

My game dev, debugger instinct tells me that this could be the real issue.
And, if this is the case, it’s clearly based on Nuendo’s architecture where the APFS formatted drives aren’t fully implemented in the code as an option.
It’s basically half done since:

  • Choose… option → doesn’t work
  • Mixdown folder → doesn’t work
  • Audio folder → works.

Also I’m suggesting is half done since

  • the message you get “folder you selected doesn’t exists” is not flagging the right issue but a generic one. The folder is right there and was created by the Choose… option embedded in the code.
    Which is another hint that Nuendo is not fully aware of the APSF file format and/or what to do if an external drive is password protected. (this requires further testing to see if it’s a constant)

Another hint that code is missing parts is that Nuendo crashed 4 times in the space of 30 mins while I was choosing the export locations.
This is probably the biggest clue. When something crashes so frequently is clearly bumping into a small void in the code, something that is not specified yet. Nuendo doesn’t know what do with it (or more likely generates a conflict somewhere in the instructions) and shuts down.

Will share this with support and see what they say.

Further testing:

I formatted a new SSD in ExFAT I have and moved the N12 project that was causing the issue:

  • I tried to export into the Mixdown folder → doesn’t work

Then I made an entire new TEST project in the same ExFat SSD

  • I tried to export into the Mixdown folder → it works

This tells me that the project itself has some data regarding the previous location stored somewhere that refers to even if it has been moved to a different external drive. (which is very likely to happen in our work life)
If this is the case, in my books, this is another void in the code that hasn’t been specified.
Or better, if I’m right, this previous location data, shouldn’t be there in first place since

  • it’s a redundancy as it’s not needed.
  • it can create issues (like this one)

In OSX, typically we run our DAW as administrators with full rights. Rarely does a newly created folder get created with lower rights, normally it is with the same rights as the user who creates the folder, anywhere in the system.

That said, I have seen every few years permissions getting wonky, but since I run Onyx for Mac every 3 months, forcing maintenance tasks, a lot of those issues do not show up. When I get a new project, always copy it to my own dedicated audio drives, which already are set to “all users read / write” with no restrictions. So I do not get issues,unless the previous engineer somehow set file permissions wrong. In which case I can batch change file permissions easily from the Command Console. But again, this s very rare.