Export

Hi folks, I posted a message the other day, but it hasn’t shown up, so I will try again.

I have this issue when I export WAV files from Cubase 8 Pro. In the picture, on the left, you can see the file opened in Notepad and on the right, you can see the file opened in Notepad after I simply loaded and saved it in Sound Forge. Note the headers for the same file are different after saving them from Sound Forge. My question is why are they different if the WAVE format is supposed to be standardised?

Now, the issue is that I need to create gapless MP3 files for the inclusion in a game soundtrack, but the file exported from Cubase is not compatible with MP3Loop. I get ‘ERROR: missing “format” chunk, invalid/corrupt WAVE file.’ whenever I try to load the freshly exported file from Cubase. My workaround is to load and save the files in Sound Forge, but I have issues with Sound Forge claiming the resources of my soundcard and every time I use it, I need to reboot my computer, which is a total pain in the bum!
Cubase vs Sound Forge Wavefile.jpg

AFAIK the Wave format is not standardised with regard to what is in the file header. Different programs save wave files in subtly different ways. When you try to load them, certain programs are unforgiving of files which do not conform to their own interpretation of what a wave file should be like.

Is it the same if you export from Cubase as Broadcast wav?

Hi there

There is a script that as you export, it immediately opens the file in the wave editor you specify!, (in my case also soundforge). Not in studio atm but do a search on export scripts and you’ll find it, very handy it is.!!

Best Regards

Dave

It is the RIFF file format which is quite flexible, see: http://www.fileformat.info/format/riff/corion.htm

Then use free Audacity to open and save exported wav file.

I am using Elements 7/8 and there is also JUNK chunk in exported audio (wav). Cubase has a good reason for use it. From Wiki: RIFF also defines a JUNK chunk whose contents are uninteresting.[16] The chunk allows a chunk to be deleted by just changing its FOURCC. The chunk could also be used to reserve some space for future edits so the file could be modified without being rewritten. A later definition of RIFF introduced a similar PAD chunk.[17]
Audacity will delete that JUNK chunk for you (46 bytes) or if you want to experiment you can do it manually. Wav is binary file so never use text editors (like Notepad) to open this kind of file, instead use binary (hex) editor (like XVI32), leave first 12 bytes (RIFFT8µmWAVE), delete JUNK and all bytes till “fmt” string, your header now should look like "RIFFT8µmWAVEfmt ", 16 bytes, first four must be “RIFF”, next four are size (always different), then four bytes “WAVE” and four bytes "fmt " (last byte is blank sign). Save under new name (just in case).

Maybe you could set your apps to use different audio drivers then they won’t conflict? I have Cubase set to ASIO and my other apps (e.g. Audacity/MediaPlayer) set to use the windows driver. I have the PC sound card output routed through my Motu device so I can hear the PC sound.

Mike.

Not tried that as I have no idea what else it’s compatible with. I know it’s probably not compatible with the program I need to create a gapless MP3 for use in the soundtrack we’re creating, but I will try it cheers. We already have the soundtrack embedded in the Xbox version which is on the XBL Indie Store, but for Steam I want to freshen up the audio.

I also found out why my first post never showed up, this is why apparently:

“The following reason was given for the disapproval:
The message contains links to illegal or pirated software.”

I never put links in at all and I do NOT use pirated software at all. I have no idea where this admin got their information from lol! :laughing:

I’ll need to try it, but in the time it’s taken for this post to be accepted, I have done most of the work anyway. I would still like to have a far more streamlined method for the future though as the missus and I are planning to make our own games and they will contain my music.

Oooh, any hints on where to start with this?

Appreciated, but we really need MP3s and they need to be gapless for looping. I’m not the programmer of the game, so I don’t know if there’s another way he could be performing this task, but I have to stick to his plan! If anyone knows of a better way to create gapless MP3s, I’d be happy to hear it, also, my computer is dying on me!!

I don’t have a problem with Sound Forge opening and saving the files, it’s just that my soundcard drivers are pretty old and I get the same “have to restart” issue with that as well. However, you’re information here is great and I will endeavour to process it!

I have three audio devices in my PC. Onboard sound is disabled, but I have HDMI audio from my GPU for everyday use and two Terratec EWS88MT audiosystems. These are the ones I use for Cubase using their, very old, ASIO driver. Even if Sound Forge or Audacity are used, I get the same issue where I need to reboot. I’m not 100% sure if it’s a driver issue, a Windows 7 issue or something to do with Cubase itself, but I also have other issues where Cubase’s internal recording level varies from project to project. My workaround for that is to boost the gain on the input channel on a project by project basis. I should probably reinstall Windows, but I’m just after cleaning out my system to accommodate my fresh installation of Cubase 8 Pro, which I upgraded to in March from 7.5, so I can’t handle any more downtime!

Try this. Close Cubase, go to Control Panel, Devices and Sound, enable on board sound card (RealTeak HD audio ?), set it as a default for PlayBack and Recording, start Audacity and do what you want to do with wav. Then again go to Control Panel, set back your default sound card for Playback and Recording and re-open Cubase.

As opposed to using the audio through my HDMI connector on my graphics card? Worth a shot I suppose, but now I’ll need to dig out a 3.5mm jack to stereo phono cable lol!! I’ll let you know if it makes a difference as I know this will bug me more and more the longer I have to do it.