Exported Midi Clicks Not in Sync with Audio Clicks

Hi,

maybe somebody of you had the same Problem with a solution? I have attached the problematic Cubase project in this vi-control thread, since 6 MB are too large for this forum :unamused: https://vi-control.net/community/threads/cubase-9-5-win-exported-midi-clicks-not-in-sync-with-audio-clicks-unbelievable-please-help.74390/

I composed in Cubase 9.5 (win) and would like to export a Midi Tempo File for the Orchestral Session (Pro Tools Recording).
Later on, I need Nuendo to be perfectly In Sync with Pro Tools at the mixing stage so both daws should at least have the exact same tempo, timecode etc.

When I export the long Midi Click (about 1,5hours) (at 960 high resolution) and import it back again in the same cubase project at the end, I would expect that the imported Midi Click should be perfectly in sync with the already rendered audio click.

Thats not the case :frowning:( - they are different at the end by a few milliseconds (analysing the waveform sync points at the end).

I really have no Idea. Is it my setup, does Nuendo Export a better midi tempo File ?
Is this a bug ? Shouldn’t they align perfectly ?

This is really confusing and kind of problematic with my current deadlines. Can anyone help or has anyone experienced this ?

Thanks,
lokotus

Hi,

Sorry, I’m not sure if I understand your steps exactly.

  1. Prepare Click Pattern.
  2. Transform it to the MIDI data.
  3. Duplicate it so it takes 1,5 hours.
  4. Connect the MIDI track to any VSTi and export it as Audio.
  5. Close the project, restart Cubase.
  6. Load the Audio file (make sure the Musical Mode is disabled), and play it back with the current Click sound.
    => It’s not in sync.

Am I right?

HI,

the cubase file I have uploaded (in the link) consists of an already made Midi Click Track (from a full movie scoring) and the Audio Click Track. Both are perfectly in sync from the beginning (Zooming in the waveform and comparing the waveform clicks to the midi click positions confirms that).

  • Now Export the Existing Midi Click Track
  • Import it Again in Cubase including the tempo map (You can import it in the Same Cubase Project after the Existing Midi Click Track (no need to import it in a new project)
  • Now Align (copy-paste) the available Audio Click Track again to the beginning of the newly imported Midi Click Track.
  • If you now zoom and analyse the newly imported Midi Click Track and Audio Click waveform, you will see that they are not perfectly in sync (analyse the whole file until the end). -> See the screenshot attachment I have uploaded.
  • This actually should not happen :frowning: Any Ideas ?

    Thanks , lokotus

Hi,

Every single computer has a but different clock. But this is probably not the reason. I mean, it could play a bit faster or a but slower, but it should be always in sync (MIDI and Audio), right?

Another idea is, these very tiny differences could be also Buffer related. Higher buffer = bigger distances.

thanks for the input. I think the error is somewhere produced when exporting the Midi File ? Obviously the Tempo Map of the exported Midi Track does not match the existing MIDI Track 100% (Some kind of rounding issue when the Midi File is Saved).
I just did another test, exporting the Tempo Track (which only Cubase can read). Importing the same Tempo Track (into a new project) has a 100% Match compared to the Audio Click Track Waveform. So they issue might be how the Midi Export is calculated …