Expression Map For Key switching in Sequence

Hello Everyone

I just picked up EWQL Hollywood Brass and I wanted to use an Expression Map to set up my keyswtiches the way I like them. After much struggle I managed to get them set up with one big problem. The key switches for my Horns wok great when I’m playing live without the sequencer running but as soon as I start the playback they don’t work.
Horns.png
In addition I have my trumpets set up exactly the same way but they don’t work at all.
Trumpets.png
I see the arrow to the left of the sequencer move but only the sound in the first position plays.

Anyone have any ideas.
Thanks a bunch.

In what way “don’t they work” when the sequencer is playing?
I don’t have Hollywood Brass, but, can you tell me please, without using VST Expression, what is required to call up a particular articulation? I can see, from your screenshots, that you are sending keyswitches, but do you actually need to also send MIDI channel change messages (i.e. are the various articulations on different MIDI channels? If all the articulations for a given preset are on the same MIDI channel, then you should leave that field blank.)
The other thing to bear in mind is that the first slot in the map is the “default” map, meaning that Cubase will always revert to it unless told otherwise.

Thanks for the reply vic

I do need to to send channel changes because the various articulations are indeed on different channels. I have to set it up this way because the EWQL “PLay” engine is very limited in setting up custom key switches.

Here is what I want to happen:
I want to record a midi track that starts with the D#0 keyswitch to activate the 3 Stac Triple articulation. A few bars latter (on the same midi channel) I want to play the C#0 keyswitch to activate the 3 Sus Marc articulation. When I play the track back through the sequencer I want to hear the different articulations. As it stands now I only here the C0 articulation.

I guess my question would be how do I tell cubase not to revert to the “default” map?

Thanks again.

G

Are you saying that none of the VST Expression events were recorded? (i.e. it plays the C0 articulation all the way through the recording, or just instead of that first D#0?)
How are you entering the VST Expression events? (by playing the keyswitch notes while recording, or by entering them manually in the Key/Score Editor afterwards?)
Also, do bear in mind that the VST Expression events have to be on the same track as the instrument they are supposed to be playing (i.e. it won’t work if you put those VST Expression events on a different track that happens to be routed to the same instrument/MIDI channel)

I guess my question would be how do I tell cubase not to revert to the “default” map?

You can only “work around” the problem… by adding a completely blank slot at the beginning of the map.

Vic

The C0 articulation is playing through the entire recordings. I’ve tried plying the keyswithes in the keyboard with the sequencer recordings and I’ve tried entering them in the piano roll after the fact. I get teh same result every time. C0 articulation plying all the way through.

Thanks again for the reply.

G

That’s really odd.
Could you upload a simple .cpr, so I can take a quick look here, see if I can spot what is going wrong? (doesn’t matter that I don’t have Hollywood Brass)

Hi, BlackLight.
What if you delete all the key switch information in your articulation map, leaving only that of MIDI channels? Will you be able to edit articulations in the key editor after-the-fact then?

I am assuming Play has one articulation per MIDI channel and if this assumption is right, one doesn’t seem to need to set up key switches.

Vic_France
Here is a quick brass template. All of the Brass tracks with “HWB” at the end have expression maps applied.
HWB Template.cpr (408 KB)
el-russo - Thanks for the reply
I tried using the key editor after the fact but did not try removing the key switches. Either way I would like to have them available while playing. I just work better that way.

G

Well, here, creating a MIDI Part on those VST Expression-enabled tracks, and entering some notes and expressions, plays back fine here. (I can see the articulations moving in the Project window on playback).
Could you please post a screenshot of the actual MIDI Part (in the Key Editor), such that it shows the notes and the articulations. (I notice that the articulations in your maps are all “Attribute”-type… that means each VST Expression event applies only to the note to which it is associated, unlike “Direction”-type articulations, which remain active until a different one takes its place.).

I’ve attached a HW strings expression map I did for 1st violin patches in the pro template folder. Maybe this will help? Play in multi timbral setup + “any” routing for the track.

I use “direction” for everything, as it seems like the simplest way to work with EM. I don’t know if this is the recommended way, but it works fine for me.

Since I’ve upgraded to 6.07 from 6.05, it seems like the articulations get triggered too late. You have to put the switch slightly in advance.
HWS 1st Violins.zip (2.14 KB)

I’ve noticed that too… still happening in C6.5.4.

Vic

I was reading a “Sound on Sound” article this morning (on the metro) the mentionted this very same thing. It would make sence that the Attribute/Direction setting would be the problem. I’m at the 9 to 5 right now but I will try this as soon as I get to my real “real” job tonight.

Thanks

I’ll check back in after I fiddle with the settings.

Yutaka

Thanks I’m loading up my template to see how this works.

Vic_France

Ok I think I see the problem. I have read that the sequencer mutes the remote keys used by the expression map. This may be my problem. When my expression maps are applied the remote keys do not register in the piano roll. I can’t even pencil in remote notes after the fact because the piano roll refused to acknowledge them…like trying to click on a grayed out link on a webpage.

Maybe this is what el-russo was trying to get at.

If I load Yutaka’s template I can now pencil in the remote notes in the piano roll but I still get the C0 articulation all the time every time.

I looked through the preferences but I couldn’t find anything that would tell the sequencer to treat the remote keys as normal keys and don’t mute them. Is there any perimeter like this floating around?

G

BL - I may not have understood you correctly, but Piano Roll is not where you edit the articulations. Open the controller lane in the key editor, and open the menu where you have the choice of controllers. On the top of that menu, you have the Articulations. Choose that one, and you are good to go.

It is normal that an incoming note that is designated as a remote VST Expression trigger note cannot also “play” as a regular note… Imagine that you are playing something in the key of C major, and the trigger note for “Staccato” is C#1. Would you really want to hear a bottom C# playing while the right hand is playing a staccato chord of C major? :wink:

There it is Guys!

I feel silly for having missed that. Got it working exactly the way I want it to. You guys are the awesume! :open_mouth: