Expression Map in Loop mode


When a MIDI part containing an articulation from an Expression Map is looped, the first note in the part switches back to the “default” articulation and only then plays the rest of the notes properly.

I have a “pizzicato” articulation defined as a keyswitch in an Expression Map, and when looping the first note goes back to legato, although the entire part has the “pizzicato” articulation running its entire length.

Any ideas on how to avoid this, short of nudging the first note forward in time (which works but is not really a solution…)?


does the piz expression start before the loop point?

Slightly before, yes (it has to in order to prepare the correct sound on the beat). Aren’t those articulations supposed to be “chased”?

That was going to be my next question. Are you sure you have chase set in preferences?

And to be honest, I’m not 100% sure expressions chase.

All “Chase Events” checkboxes are ticked except SysEx.

Normally the are chased because if you start playback in the “middle” of an expression (i.e. after its start point) then the articulation sounds properly (which is the whole point). It should do so on loops, too. I don’t know why it doesn’t.

Also, the manual says: “When Latch Mode is activated, the key you press is valid until the next key is pressed.”

This is of course the Expression Map Latch Mode, nothing to do with automation.

I have Latch Mode enabled, so the articulation shouldn’t change no matter what, until I press a new keyswitch. In my case it not only resets to the first articulation when looping, but also when stopping playback.

can’t test right now, sorry. I loop with expressions quite a bit, and I’m pretty sure it chases properly. It will probably be late tonight, or tomorrow before I can look. Maybe someone else has a clue.

I have four weeks of intense Cubasing ahead of me, I can wait 24 hours :slight_smile:

Try reprogramming your expression map, leaving the default articulation slot empty. That is, having your articulations begin from the second slot.

Excellent workaround, thank you very much. The display in the Inspector doesn’t correspond to the articulation being played, but at least the sound does which is what counts :slight_smile:

Steinberg should really fix this, the Latch option not behaving like it should.

Thanks again.