Expression Map Mystery

I really need some help to figure this out once and for all :

  • I have a custom Playback Template with all needed Endpoint Configurations
  • I open a new empty project
  • Everything loads as it should
  • I edit an Expression Map
  • I increment the Expression Map version and click “ok” to close the dialogue
  • I save and replace the Endpoint Configuration of the related instrument and quit Dorico
  • I start a new empty project
  • I load the same instrument
  • I open the Expression Map and it is still the older previous version

What am I missing in order to have my newly edited Expression Map to load in all new Projects ?

@Emmanuel_Cambier the only thing that I can think of: can you check in your prefences if this option is checked?
(and maybe post your project, with related PT and EC, for us to check?)

Thank you Christian for checking in,

I had actually forgotten about this Preference, unfortunately it was already properly checked :

Here is a test project, just in case :
Expression Maps Test.dorico (1.8 MB)

@Emmanuel_Cambier

I tried and I found that after the 6th point in your list…:

…you need to go into the Playback Template, edit it with the pencil, and delete and re-add manually the Endpoint configuration to the Playback Template. (It seems otherwise to stay with the old one, even if the new has the same name.). I hope it helps.


EDIT: I found that, instead of deleting and re-adding the Endpoint Configuration, If you increase in the Edit Playback Template the version nr. it also works…

I just tried your workaround but I got the very same result as before… and there is absolutely nothing in the Manual referring to Expression Maps updating procedure !!

I was under the assumption that over-writing the End Point was the logical guarantee that the instrument would thereafter be linked to the new Expression Map version !!

This seems like this part of the workflow needs some serious improvement … unless we are both missing something obvious !

After creating the new project, and “load the same instrument”, did you then tried to re-apply the Playback Template?

(sorry that I cannot help further, with your file, because I don’t have your libraries, and it is also asking the playback template that correspond to it…)

this is probably true, even if in my simple tests I managed to have the PT update with the “version numbers”… But this is indeed a little complex thema…

…I found a thread that seems to treat this things… (I don’t know if @PaulWalmsley eventually could help with this):

Thanks Christian,

I have just read and commented on the thread you shared !

1 Like