Expression map not working on VE Pro Port 2

In a VE Pro instance I have articulations on channels 1 and 2 of Port 1. In Dorico the VE Pro plug-in is routed to Port 1, channel 1. I have an expression map which sends one articulation to channel 1 and the other to channel 2. This works.

If in VE Pro I put the articulations on channels 1 and 2 of Port 2, and in Dorico I change the plug-in routing to Port 2, channel 1 (without changing the expression map), both articulations go to channel 1.

Similarly if I put an instrument on Port 1 channel 1, I can switch its articulations using an expression map and CC messages. But the same expression map doesn’t work if the instrument is on Port 2 channel 1.

Is this normal?

EDIT: Possibly connected with this thread?

The only thing that comes to mind is that your plugin instances are set to ‘omni’ or ‘all channels’ depending on the terminology of the plugin?

there have a been a few threads on this – the one below was one of the most detailed and might help. I’d ask if you’re using the vst2 or 3 version of VEPro as to the best of my knowledge, there are still issues if using .vst2 as can be seen in the thread? Dorico and VEPro Port 2 and beyond

Frankly, I avoid these difficulties by only using port 1 with VEP but I know there are circumstances where this approach is not ideal.

Thanks for these suggestions.

It makes no difference whether the plug-in is set to Omni or channel 1.

I am using the plug-in called simply “Vienna Ensemble Pro” in the menu in Dorico 5. I assume this is VST3 because according to the plug-in settings there are 48 ports.

That thread seems to be mainly about difficulty in getting any sound from Port 2. I am getting sound, it’s just the expression map that doesn’t work.

Yes, I may have to go back to using just Port 1. But it’s a bit frustrating: I can use multiple ports in Logic, and I’d like to use the same server project for Dorico too.

You should be able to use multiple ports in Dorico. I use at least 12 with one VEP instance in one of my larger templates. Are you sure the endpoint setup reflects the expression maps for both both ports? Meaning, when you change the routing, did you also change the expression maps from port 1 to port 2?

1 Like

Aha! That’s what I was overlooking!

For the benefit of anyone equally challenged who may come across this thread: you have to open the Endpoint Setup dialog, change “Number of MIDI ports” to whatever you need, click the “Set” button (which at first sight looks as if it relates only to the number of channels), scroll down until you see the port you want, and ensure that the channel in question has both the right instrument and the right expression map.

Thank you so much!

Ah, I assumed in my naivety that you’d already done this! But of course, as you said, your problem related primarily to a wrong EM so that should have set alarm bells ringing…

1 Like