Expression Maps again - Keyswitches are triggered inconsistently

Wow. Thank you so much. I will try it as soon as I can. I hope I understand everything correctly! My I ask you again if something is not clear?

Sure. Can’t guarantee when I have time though, obviously.

1 Like

Sure! Thank you :pray:

I still try to figure out how to make it work (haven’t had too much time yet). But I can’t find the information which base switch is on and if it is bowed or not. Can’t find it in the manual and in no video I’ve seen until now…

In the Key Editor, when you hover over regions in the Playing Techniques lane, you’ll see info about switches and active techniques. That’s where you can check the results of expression map edits.

Thank you again.

First: fixing the pizzicato problem was simple. I forgot to put in the keyswitch to natural in every note that is created via cc from it (staccato uses the natural note but with higher velocity…)

But then there are tho other problems. I spent the whole day searching for videos and reading the Dorico manual. But they all seem to scratch the surface of how you can create XM. Thanks to this forum I manage to solve most of my problems. It’s not like I don’t try to help myself first.

So @Lillie_Harris or other people of the team hanging around here. Can you help me with the two (for now) left problems?


In this example, which I posted above, either the accented notes play col legno or the not accented notes do. It depends on which note is played last… same with pizzicato. So the accented notes seem to cause the problem. I didn’t set accents up in the XM. Just using the playback rule from Dorico.


In this example I notated a Bartok Pizzicato. It is played… but only when the note before is natural. If it’s normal pizzicato it will just play a loud pizzicato. (Bartok pizzicato is generated by playing Pizz at velocity 127).

I will post my updated XM in a few minutes. The Dorico files are above.

I really don’t want to waste everyone’s time. Maybe there is a in depth explanation (preferably in German) how to set up multiple techniques… maybe that could solve the problem. Or on mutual (?) groups.

@dspreadbury you were named as an expert for xm above… made you can point me to a good tutorial or have a simple solution.
Again: when playing pizzicato or col legno (and possibly other articulations) they get untriggered when any other articulation is played. even if it is not set up in the xm. so an expression the uses an accented pizzicato should do the trick. I just can’t figure out how to do that. Or what an “additional switch” does…
also Bartok Pizzicato is only played, when a natural note is the note before. when its (normal) pizzicato Bartok playes as loud pizzicato.

I think you might need to explore the difference between playback techniques attribute (affects one note) or direction (switches on until it is switched off or replaced). These are defined on the Library>Playback Techniques dialog.

1 Like

Thank you of the tip. It sounded promising. but it didn’t help. I need to tell Dorico, that Col legno/Pizz together with an accent should play the intended articulation, but louder.

Then you perhaps need to define an XM entry combining col legno + accent? Something like…
swith

Just to add to your earlier question…

Add-on switches are useful where (eg) a VST has a separate switch for things like con sord or vibrato which is in addition to other (long/short) articulation switches.

1 Like

I tried it. It doesn’t work. I also tried a mutal group. it then makes other problems… I have to sleep now. its 01:30 in Germany

You are working with a VST that few of us have experience of, so all we can do is guess. Sorry, I’ve run out of ideas.

You’ve done this already, which means, it seems to me, that the problems are with how the VST/library responds. Unless someone with experience using this library with Dorico can point you to a specific issue, I would troubleshoot focussing on the switch actions (key switches, CCs, etc.), how the VST responds, and the timing (including “Expression map switches before notes” which I mentioned above).

Try different things. For example, you say:

Look at the Playing Techniques lane for this example. The snap pizz. note triggers the snap pizz. switch, and the notes before have triggered the pizz. switch. The only difference between the 2 switches is the velocity range: pizz. is 1-127; snap pizz. is 127-127. All that seems correct based on what you’ve said. So what could be wrong? Could the VST be running out of time to switch patches? Does the library require some other key switch, CC, or configuration to behave as you expect? Something else? I’m just brain storming… Some things to try:

  • Slow the tempo way down.
  • Move the snap pizz. note a bar after the pizz. note.
  • Export the audio. Does the problem occur there too?
  • Disable the snap pizz. switch, and set the snap pizz. note’s velocity to 127.
  • Play around with “Expression map switches before notes” setting.
  • In the snap pizz. switch, insert key switch C2 before key switch F2.
  • Watch the VST interface as you do these things. Maybe there’s a clue there.
  • And of course search the VST/library forum and documentation, and contact their support too.

Setting the key command for natural to „note off“ did it for the pizzicato. A big thank you!!! This might also work for the other Problem. Basically every note is told to switch the keyswitch on and of again. Will try I later and report here

1 Like

Hurray!!! It works for the other problem, too!!! Thank you everyone for the good advices.

1 Like

Well… it nearly works. The first note (only the first note) plays natural when accented (col legno is notated). All following Notes play as expected. No matter if accented or not.

I’m not sure exactly what you did to improve things, but you mentioned something about note-off actions. I’d double check that key switches which are supposed to be note-on are set correctly. Also, have you tried editing the init switch?

I now works as expected. didn’t change anything but closing and reopening Dorico again