Expression maps not workly correctly during normal playback

I’m new to Dorico and trying to write for the first time in the software this week. I have Spitfire’s BBCSO Pro library so I installed the Expression Map that Dorico provides for that library.

I’m having an unexpected behavior that seems like a bug but I’m trying to understand if I’m just using it incorrectly. Here is an example of what I’m seeing:

  • I have a bar that has 4 quarter notes marked with staccato.
  • If I click on them to select them, it sounds with the proper staccato articulation. I can also see that by having the VST window open to that instrument, it switches to the staccato articulation. If I click on a long note, it switches to Long and plays that correctly as well.
  • However, if I hit the play button in Write or Play mode, it just plays everything as a Long articulation, never switching to staccato.
  • If I use Shift+P and write in Spicc or Pizz above the bar, it plays those correctly during playback, but it seems like it’s ignoring individual notes style during playback.

Am I missing something about how this is supposed to work? What can I do to get it to playback properly?

Edit: In playing around further with the Expression maps, I’m finding that if I edit the “Natural” key switch to the same one as is set for Staccato, then instead of sounding long notes, it plays staccato. So said differently: It seems that Dorico is playing the “Natural” setting for everyone even when notes are marked with staccato dots in the score. The expression map has a key switch defined for Staccato but it seems that it’s being ignored?

Thanks in advance for any help!

Attaching a sample project file and an export audio. If you listen to the audio you can hear that the spicatto marking in measure 2 has no impact on the playback. However the pizz and spicc markings in the last 2 measures do.

Testing Articulation Issue.dorico (605.5 KB)

Hmm, for some reason the forum won’t let me upload the mp3. It keeps saying I “can’t include a link”. But I’m just using the upload button in the editor.

My guess is this new setting in D4.3

Change it to 1/4 note (crotchet), or disable it.

That fixed it! Thank you!! Sorry for being daft/new to all of this, but what was that setting trying to accomplish? What’s the downside to changing it to 1/4 note?

You can read about that option in the Dorico 4.3 Version History PDF, and indeed it has a reasonably lengthy explanation shown immediately below the option itself, so you could start there! :slight_smile:

The idea is that if you have a recorded staccato sample in your patch, you want Dorico to use that regardless of how a note happens to be notated in the score; with that option switched off, Dorico would play a note of a quarter in duration written as a single quarter note using your staccato sample, but written as two tied eighths simply by shortening the duration of the written note.

However, it appears there’s an unintended side-effect of using this option that is preventing the normal shortening from working correctly, which we will look into as soon as we can.