External Editor leads Wavelab Pro 11 to Crash

I’ve been working with RX 7, 8 and 9 linked on the Wavelab’s Ext. Editor section with any issues at all.
Then, out of the blue, this issue started to happened: After selecting the piece of audio that I want to edit, it opens the Rx of my choice but when I Save the RX edited file, Wavelab closes unexpectedly. This is happening all the time and is valid for RX 7, 8 or 9.
I also found out that I’m not being able to delete all of my Ext. Editors List. There’s always at least one of them that comes back, after deleting them and relaunch Wavelab. (see video)
Please also find attached a crash report.
Any help would be so much appreciated.

WaveLab Pro 11_2022-02-08-110819_Mac-Pro-51.crash (124.8 KB)

WaveLab automatically populates these fields if the external applications are found on the computer.
Concerning the crash, do you get it also when used from the audio editor?

Thanks PG for your quick answer.
In fact, if I call the External Editor in WL Audio Editor, everything is working perfectly well. It only happens in the Montage (where I do all of my work).
In the Montage, besides the crash issue that happens every time I save the edited file in RX, when I select a piece of audio to edit, the External Editor doesn’t create a new file in RX and keep the old one to edit with the old time stamp. So I have to delete all files from the editor in order to have just one there with the correct time stamp.
Just to remind you that this irresponsive Ext. Editor behavior is only happening in the Montage. In Audio Editor is working fine.

Just to let you know that I’ve just deleted everything I had in the computer regarding to WaveLab Pro 10, but it keeps creating a cache folder for WL 10.

Hope you can help me fixing this out.
Thanks a lot.

Is there something unique about the path of your session that would not allow WaveLab normal access to the “Data” folder that it needs to create to put the edited files when using this method?

Justins asks a good question.
When editing a file in an external editor, two files are created: one in the cache folder, and one in a sub-folder of the montage. These two paths must be writable (WaveLab auto-creates the directories).


Maybe a clue is that even though he has uninstalled WaveLab 10, WaveLab 11 keeps making a WaveLab 10 cache folder.

Cache forders are editable in WaveLab, in the preferences.

Thanks PG, I was checking that out right now. Mine are configured to:
/Users/ruidias/Library/Caches/Steinberg/WaveLab Pro 11
which seems ok.

The Crashes issue seemed to have disappeared at the moment that I deleted WaveLab Pro 10.0 related folders. But I’m still not able to use the External Editor in the Montage.
Please take a look at the attach video, where I delete Steinberg cache’s folder and as soon as I launch WaveLab 11 two folders are created… WL 10 and WL 11 Cache folders.
Then I create an empty Montage, import an audio file and try to edit it with RX7. At the first attempt it creates a new file on RX, but on the 2nd attempt the file to edit is still the same…it doesn’t add a new file to edit.
Remember that this situation only occurs in the Montage. Audio Editor is working perfectly well.

I’m also attaching a foto where you can see the “Data” folder of this Montage created by Wavelab 11 which has the same information of Wavelab 10 Cache folder. So it seems that WaveLab 11 is creating its cache under WaveLab’s 10 folder.

I’ve already reinstalled WaveLab 11.

In your video, you seem to use the External Editor in the Montage, no?

To edit the folders, do this:

Thanks PG.
In fact, “Companion Files” was generating the creation of Wavelab’s 10.0 cache folder. I configured the “Companion Folders to WaveLab 11, now the WaveLab’s 10.0 cache is gone, but the issue with the External Editor persists.
So I decided Once again to delete everything that was WaveLab’s related and this time did the same with Izotope’s RX 7, 8 and 9.
I also decided to upgrade my OS from Mojave 10.14.4 to Mojave 10.14.6. I can’t go any higher since I’m in a 5.1 Mac Pro.
Reinstalled WaveLab Pro 11 and all RXs.
I’m still not being able to use RX like I used to (Please watch the video with sound, I exagerated on the RX settings so the diference could be heard easily). Every time I call the External Editor, it doesn’t create a new file to edit on RX (this is valid for all RXs). Note that this only happens in the Montage. In the Audio Editor, it works as it should.
Randomly I receive this message from WaveLab and I think it doesn’t make any sense because I don’t do anything to trigger it: “An externally edited audio segment was modified, but ‘test rx.mon’ was modified since the editor was invoked. Are you sure you want to import the change?”
I think I’m really stuck in here.

Well, I don’t really know why it does not work for you. In case this rings a bell, the system works like this: when you call RX, the clip region is first copied inside an independent audio file. Then WaveLab watches for a new file stamp for this file. If/When this happens, WaveLab assumes the file was modified, hence WaveLab replaces the clip region with a copy of this temporary file.

After your RX editing, try to quit RX to see if that changes something.

Any chance to try with another external editor, such as Spectralayers?

Thanks PG.
Unfortunately I don’t have a way to try another External Editor besides RX.
Anyway, you suggested me to quit RX every time I edit something. In fact it works, if I unselect the “Reopen Previous Audio Files When App Starts” on RX preferences.
So every time I call RX through Wavelab, it creates only one file to edit. If I quit RX every time I need to edit something, it will open the (only one) correct file to edit.
Let’s see if I manage myself to work this way. At least I’m now able to use it.
I’ll let you know if I find anything new about this issue.
Thanks a lot for your help.