External Effect and delay compensation (echoes)

Hi there,
I ususally use my Avalon VT737sp sometimes as an external effect, which works quite well and flawless in Logic and other DAW programs. With Wavelab11 it just only “kind of” works.

The Avalon is a single channel strip and therefore mono. I set up one send channel (line3) on my Apollo to the Avalon and chose channel 1 for return (input). Under preferences I set up the corresponding channels for send and return (each set on “left”) and the “External FX” plug-in tests for a latency of 17ms and all meters work flawless. Used in a montage on a single track, on a channel, clip or where ever else, I get echoes so listening is unusable without muting all other channels of the montage. Anyways, rendering one track, clip, channel with the “External FX” works nice and perfect to the sample, if audition is switched off.

I have no clue, whats going on here. It appears to me, as if the plugin works, but there is no delay compensation regarding the rest of the tracks in the montage. At least not while playing back. Delay compensation seems to work while rendering if audition is turned off.

Have a nice day,

you can’t hear an echo of 17ms, it would just introduce comb filtering
must be something else if you get real echoes…
I would search in “Console” first…

Thank you for your help!
True, and that is what I checked for first (Console). Muted all Aux and Send, disabled tracks etc. But with the same console settings it works like a charm in Logic. The echoes are more like 170ms or more by the way. External FX states a latency of about 17ms.

To maybe better describe the echoes:
Let’s say you have two tracks, not really stereo, but something like a boom and a lavalier with some bleeding to each other (bleeding is not the issue, but makes it better audible). Track 1 is the Lav, track 2 Boom. External FX is on 1 and sounds perfect if track two is muted. So track one is clean in this situation. If track two is on, you get echoes of about 170ms. If you bypass External FX on track 1 everything is fine again, too. If you leave both tracks on plus External FX on track 1 and render track 1 everything is also fine and accurate to the sample. Although auditioning while render is horribly echoed and needs to be turned off. Therefore I don’t think it is Console.

But as I said, no clue…

By the way, the slider for setting up the latency on the ExternalFX plug in (left most slider) does absolutely nothing here. No audible or measureable changes.

I tried something…
If I send the signal out to the Apollo and have the faders of these channels up I have the same delay as you…

Hmm, interesting.

There seems to be something wrong here. Which Apollo do you have? Maybe you could send the console config to me so that I can try your config?

Kind regards,

Twin USB
I did not connected any hardware, just tried the Virtual ins and outs with a plugin in the input…
since there is no access to the virtual outputs
These Apollo integrated mixer is not that easy to understand…

I remember a live show where the FOH guy of a band did some external processing with his Apollo and had some problems finding the right setup… on one point we had a useful configuration and left it alone, but we were both not sure why it was working now… :wink:

I have the same, but just the thunderbolt version. Shouldn’t make any difference.
Regular vst plug-ins work perfectly by the way.

When you say that the latency adjustment slider does nothing, are you saying that you can change the delay ms number, but it has no effect on the delay you hear? Or that the slider doesn’t affect the latency amount? In other words, you can’t change this number. ?

I can move the slider, which changes the number, but without any audible effect. I can’t hear any change. Even with extreme settings, which should induce somewhat of a delay, there is nothing audible here.

I tried something else and put a delay of 220ms on the second track - the one without the ExternalFX - and everything is in sync again. BUT timecode is now off, of course. So that is no way to go.

So, I took the plunge and installed Wavelab 10 again. Here it works as expected, no echoes. Although the latency slider seems to have no effect here, too. I’m on MacOs 10.15 Catalina.

I hope Wavelab 10 and 11 as a parallel installation is no problem.

No problem…