External FX issue,bug?

I was using external FX successfully.
But now that I try to add a second external FX unit nothing works.
WIll remove my preferences and back to only one external FX unit.


Could you be more specific, please?

Adding a second external fx unit makes external fx not to load.
And only appears one unit.
Studio,audio connections,external fx,add two busses,rename them to “insert 13-14” and “insert 15-16”,then select audio device (AIO Pro) then select sends bus channels for both busses (13-14 sends to adat 3-4,15-16 sends to adat 5-6),then select return bus channels (13-14 to adat 3-4 and 15-16 to adat 5-6) .
Only one external FX appears at channel settings,inserts (not the two created) and selecting it don’t load anything,external fx don’t work anymore.
WIndows 11 (last update),Cubase Pro 12.0.20.


How do you do this?

What happens, if you click the Add External FX button again in the Audio Connections > External FX window, please?

“How do you do this?”
Clicking on the add external FX tab and ok one at the time to create two external fx.
Clicking add external fx opens the window “add external fx” and clicking ok it adds the external fx,and the routing seems normal but once I try to use them at channel settings inserts under external fx only one appears and don’t open nothing.
The point is that I was working fine with one external FX.
Adding a second one cause external fx failure.
Later I’ll upload images.

On the last image clearly you can see the two external fx modules at audio connections but only one show on plug in list.
After select it nothing happens and then the error window appears.

I trashed my preferences folder completely and on an empty project external FX worked.
Two instances as they should.
Then after restore some of my preferences they went broke again.
I don’t want to re do all my preferences so do you have an idea about which file inside preferences could be the culprit?

Kind Regards

Post the crash dump file shown in the error message here and perhaps Martin or one of the other experts can take a look for you.

Nope,the crash has nothing to do with the issue.


I can’t reproduce it here, but I have found an issue in this area, which might be related.

What happens, if you quit Cubase and start it again? Does the 2nd External FX appear?

No it doesn’t.
I removed preferences and created the two external FX on an empty project.
Then I placed back some files at my preferences.
The two fx remain and seemed to work but then I removed one and insert it as a send fx and all got damaged again…both external disappear as before.


Did it work?

Did you quit Cubase before? Which files exactly?

What do you mean by this? Removed from where?

“What do you mean by this? Removed from where?”
Remove the external fx 2 from insert (channel settings) and tried to load it as a send fx (channel settings) .

“Did it work?”


I moved key commands,plugin manager,all VST plug ins related,midi devices,vst quick control midi,Project Templates,panels,cubase panel images,and user preferences.

As I stated before it must be some file at my preferences that gets corrupt as soon as manipulate audio connections on external fx.
I haven’t found the file that contains the information about all audio connections which I think could be the culprit.
But since I’ve lost so much time with this I’ll delete my preferences folder and will reconfigure Cubase again.

I think that I’ve found the problem:
Plug in manager file.
I replaced again my preferences but this time avoid plug in manager file.
All works as expected.
Since I’ve used a personalized plug in collection I forgot to add the new “external FX 2” to the collection folder,that’s why the second external FX was missing at channel settings.

Nevertheless something should happen too cause despite “external FX 1” shows at insert it didn’t load…maybe manually update it at VST plug in manager was required or the file just got broken somehow.
All work fine now.
Btw updated to 12.0.30 too.
Thanks for your kind support.


Man, I am glad you posted this.

I was having an issue very similar where my external effect would show in routing and in external effect folder but would not sound or launch.

Your suggestion fixed it.