external gear with 7.2 not working the way it should

I just downgraded to 7.10 again because the issues i had with external gear are still there as well which is a no go for me.

I don’t use the render function but i record what is played back (i want to hear what is going on and rendering simply doesn’t do that) and when you press play when the audio is right at the start of a file than there is audioskipping going on (i think) at the time that your buffer is set to. Same goes for the end of a file, it stops playing audio before it actually stops, again at the time the buffers are set to.

Sure i can add silence at the start and end of the files as a workaround but i don’t want a workaround, i want something that works…

BTW, these issues where also an (known) issue in 7.1.1 and so i use 7.10

PG? could you shine a (christmas) light on this?

Hi,

How do you setup with External Gear, I mean hardware IO
and routing in Audio Streaming Settings dialog and is this
with OSX or with Windows !? just like to understand, thanks

regards S-EH

For the External Gear, I don’t understand how 7.10 is better for you than more recent versions, because versions <= 7.10 definitly had a flaw that could introduce audio gaps. And 7.11 has solved the case of many users. Re-studying this plugin won’t happen in the near future. Sorry.

Please check the way i work and try for yourself… 7.11 was not working the way it should as well! I came up with this a couple of times already and described the way i work (and a lot of PRO mastering-engineers) also a couple of times. Search for my username and find a few topics and posts from before. I also used the test version of 7.11 that you’ve mailed me and I mailed you back about the problem including examples and everything.

Not re-studying this problem will not be a good thing for sure…
I really hope you will test it for yourself because it’s 100% sure not OK!!

no response at all? come on guys! :imp:

For me, rendering is just a process of fixating to a new file what was evaluated during playback and tweaking - “hearing what’s going on”, as you say. I don’t see any reason to monitor during render. That doesn’t mean you didn’t find a bug, but maybe not so many people work the way you do.

Luck, Arjan

Well… actually most mastering-engineers working with wavelab work this way because you (and attending customers) want to hear what is going on.
In case of dropouts (which can always happen since you are working with a computer) can be heard in real-time and not after you found out that a dropout accured after 1 minute while the rendering took 6 minutes. That is at least 7 minutes lost.
Recording is the only way since rendering still doesn’t support playback in realtime.

Just a reminder about the external gear and their users having problems with it: http://www.steinberg.net/forum/viewtopic.php?f=47&t=2793&sid=0da1e40f1c086953355c80a21c80e36c

The dropout issue described in the above thread, has been corrected by redesigning the external gear plugin in wavelab 7.1.1 (a flaw was clearly identified). This has been extensively tested. It is recommended, however, to use at least 512 bytes asio buffers when dealing with 44.1/48 khz streams, and more for higher sample rates. And to set enough buffers in the asio streaming preferences. Did you try that?

Hi Philipe,

Thanks for the answer. My buffers are set to 512 already, it doesn’t even play when set to 256 or less. Higher doesn’t work at all, tried that.
Like i said, it’s not that i have dropouts, it’s the fact that when re-recording (what most engineers do because you can hear what is going on) you have a dropout/glitch exactly after the buffer time and the audiofile stops playing audio before the file is actually over. It stops playing at the set buffer time, though i didn’t 100% check if it is exactly that buffer setting. In between everything is fine and worlks the way it should. It’s the start and end that is not the way it should.

I use an RME hdsp9652 with a lucid 88192 converter running on win7 32bit on an asus p5b mainboard with dualcore cpu. I’m thinking of upgrading to a new mobo with new cpu but in the nearby future because it’s more than fast enough.

Can this be that the RME HDSP 9652 and Lucid 88192 have together or other HW-Audio combo
buffer/latency which is not known for WaveLab and you can’t ping the round trip in WL
like you can in Cubase / Nuendo and that’s why there is a start and end buffer missing !?

regards S-EH

Don’t know for sure but i think that is not possible. All i know is that it wasn’t a problem before 7.11.

OK, i did some more testing, this time with an example of the differences between 7.10 and 7.2 (i have both running side by side now)

Ok, here’s what i did:
wavefile 24bit/44.1khz with no silence in front of the file but pointy kickdrum at the start from exact beginning.
Then i inserted the following pluginn chain: psp neon > external gear > ozone 5 > fabfilter pro-l
Then i pressed record and selected as input '"playback’s output (record what is played back)
Then i pressed play and stop 4 times, first 2 times are done with the external gear bypassed, last 2 times with the external gear engaged. (you can hear the difference in sound because of the hardware for easier recognition as well)
In the wl7.1test file you can hear that both work fine, with and without external gear. The attack of the bassdrum is intact, the way it should.
in the wl7.2test file you can hear that with external gear bypassed it’s ok but with external engaged you can hear the missing bassdrum attack and the end is also missing, even though i stopped playing right after the bassdrum was done.

I did this with the external gear latency set to auto but it doesn’t matter at all where i set this for this test.
The buffer was set to 512 and if i set it to 256 it’s better but the attack is even more gone when set to 1024.

Judge for yourself, exact same system, exactly the same chain, only difference is 7.1 and 7.2
http://www.dagoosemusic.nl/temp/wl7.1test.wav
http://www.dagoosemusic.nl/temp/wl7.2test.wav

Using both External Gear and the mode “record what is played back” is not a setup I have much tested, I must say.
You should try the Silence plugin, to insert silence at the start and end, and cut exactly the extra audio afterwards.

I know that will work but that is a workaround like i described earlier.
Could you please review the problem? that will help a lot of people because, like i said before, a masteringengineer wants to hear what is going on in realtime. Specially when you have an attending client.

I guess a function “audition while rendering to file” would be more appropriate than the workaround you do, with the recorder.

True! i think that a lot of people will be really happy with such a function! Please do so!

I was already hoping for this to be in v7 since a lot of people asked for it in v6 already.

Oh yes, I’m all for that! I don’t use external gear, but this could indeed be very useful as a final safety check while rendering. Great idea.

Luck, Arjan