External Instrument Can't be Assigned to Instrument Track

I’ve been trouble shooting this issue all day and I’m at my wits end. Hoping someone can provide some guidance.

I’m setting up my Alesis QS8.1 as an external instrument so that I can use it like a VSTi within Cubase. I’m able to configure everything as instructed in the manual and in the handful of YouTube videos that I’ve watched on the subject. However, when I go to create an instrument track and select my external instrument, it will not assign to the track. I select the instrument from the drop-down list, but after I select it, the value returns to “No VST Instrument” and the assignment fails.

The connections and configuration are as follows:

QS8.1 left and right audio outs into a small line mixer. Line mixer outputs to the aux in of the Omni I/O break-out box, and routed to inputs 3/4 of the Delta 66 card. Inputs 3/4 are free and available for use with the line mixer. Created a new MIDI device using the QS7 device in the device list, and connected to output A of the MIDISport 4x4. The QS8.1’s MIDI ports are connected to input/output A of the MIDISport 4x4. In VST Connections, the QS8.1 MIDI device is configured to return audio to input 3 (left) and 4 (right) of the Delta 66.

I’ve tried configuring the external instrument many times now, with no luck in being able to select it when creating an instrument track.

The hardware/software details are as follows:

Cubase 8.0.40
WIndows 7 SP1 (Intel i7 CPU, ASUS P4P-700DX Mobo, 16GB RAM)
M-Audio Delta 66 PCIe Audio Card wit Omni I/O break-out box
Midiman MIDISport 4x4 USB MIDI interface
Alesis QS8.1 Synth

All drivers are updated to the latest versions.

Can anyone provide some ideas on what the issue might be? It’s been highly frustrating to configure this exactly as instructed and demonstrated in YouTube videos yet have it now work on my system!

Thank you.

Hi,

Could you attach a Screenshot of your External Instrument settings, please?

Thank you for your reply. Here are three screenshots of the setup:




As can be seen, I’ve added the MIDI device and connected it to the appropriate output of my MIDI interface, added the external instrument in VST Connections and setup the return bus inputs to which the external synth is connected, but the external instrument does not appear in the drop down list of VST instruments when creating an instrument track.

I’m at a bit of a loss. Any help is appreciated.

Thank you.

Anyone have any ideas?

Seems you did everything right. I don’t know your port names, but this is what I normally do. if this doesn’t work, please trash your preferences, something else must be wrong.

  1. Create a new external instrument and assign the right audio inputs inputs (seems ok)
  2. got to midi device manager and create a new midi device, linking the correct midi outport port
  3. link the midi device to the external instrument in the same window as 1

press F11 and see if it’s vissible in both RACK and TRACK instrument (rack being for multitimbral and TRACK being for a single INSTRUMENT channel)

Thanks, Raphie. I’ll try trashing preferences.

Hello,

I am having the exact same problem with Pro 9.5 as cobra2935. Did you ever resolve this issue?

Hi, found this thread today while experiencing the exact same issue but it only occurs in C10 and C10.5. VERY frustrating.

Hi,

It works to me here on Cubase 10.5.

Martin it would be more helpful if you would tell us how you got this to work. Screenshots Etc.?

Hi,

I was just following Raphies’ step by step description. And it worked.

I recall having followed Ralphie’s instructions and it still didn’t work for me, but I did eventually get it to work, though I don’t remember how at this point. I’ll check in my system when i get home tonight and see if I can remember what I did to resolve the issue and post back if so.

Hi,

Please see attached animated GIF. I hope this helps.

Martin,

Thank you for the video. Looks like you put a lot of work into it.
Unfortunately it still doesn’t work on my system. I did notice that your layout and windows etc look entirely different than mine. Most likely because your on MAC and I am on WIN. It sure is baffling. Maybe it’s only broken on Windows version?

Hi,

I have just tried in Cubase 10.5 on Windows. The result is the same. It just works to me here.

Dang Martin. I’m jealous. Thanks for the feedback bro. Fortunately this is feature I don’t use often. When I do need it I can launch C9.5 workaround that way. If you find any new info on the subject I’d appreciate it.
Joey