External instruments problem in Cubase 5

Hi—I’ve been trying to connect my Kurzweil K2000 all night to Cubase 5. I have set up my input and output devices in VST Connections, but in external instruments my output device shows up as my headphones’ mic only. There is no selection for speakers. My headphones are connected to the computer with a USB. I briefly got the K2000 to work as a MIDI controller, but I’m trying to use the synth’s audio itself. What are the exact steps to configure that? The local control is set to MIDI on the K2000 itself… is that an issue? The computer is capturing the K2000’s signal, but I can’t hear it. Using the UM-ONE Mk2 MIDI interface by Roland.

I feel like I might be trying to do 2 things at once and that’s where I’m getting tripped up

I guess that you are using what was the full Cubase 5 version, at the time (others were Studio and Essential, if I remember well.

Not sure that I got what you are stating, but… There doesn’t need to be a ‘Speakers’ option, as soon as you have a functional Stereo Out bus.

To do that, you should add an External Instrument in the dedicated panel …

[…retrieving his old Cubase 5 Operation manual, on paper format… yes, page 24…]

… and to do this (it’s not different in Cubase 13, actually), you should have a Kurzweil MIDI device already set up. This will allow you to use your K2000 as any other VSTi.

So, what I would basically do is :

  1. If not already done, define a MIDI device (Devices > MIDI Devices Manager- Operation manual, p. 327) : this will allow you also to define a patches list of your instrument.
  2. Check that you have BOTH audio and MIDI connections between your audio/MIDI interface and the K2000. As an old fart, I always prefer using MIDI DIN cables instead of any USB connection. beside this, I would set the local control at OFF, when using the K2000 with Cubase.
  3. At the end, add the K2000 as external instrument in the VST Connections window.

Additionaly, how do you check that your setup receives the audio signals ? A screenshot would be welcomed, on this matter.