External Instruments - using the same synth more than once with different sounds

Hi everyone

I’m a relative newcomer here but will be grateful of some advice.

I have hardware synths which I am hooking up to Cubase 12. In particular I have a Blofeld desktop which is multi timbral. I’ve set this up as an external instrument which works fine but I cannot seem to be able to add another Blofeld on a different channel and then record a different instrument.

Is there any way of getting around this.

What I’d like to do lets say is:

  • Have Blofeld 1 with a particular patch
  • Have Blofeld 2 with a particular patch

And so on up to 16.

I don’t have a clue how to do this.

Kind regards

Johnny Winto

Hello and welcome.

First of all you need to make sure you’re Blofeld receives MIDI on different MIDI channels for each patch.

For the first patch, create an Instrument track and select Blofeld as it is setup as an external instrument.
For the second patch create a MIDI track (if the above track is selected you can make a double click with the mouse in the blank area of the track list). Set its MIDI output port to the Blofeld and chose a MIDI channel that matches that patch in your synth.
For any other patch create another MIDI track with the a/m settings.

Obviously the audio will be delivered from the synth to Cubase through the same audio cables.

1 Like

Blofeld is a multi-timberal synth which means what Johnny said above.

And just to clarify, you have 2 Blofelds? A desktop Blofeld plus another Blofeld?

I just have the one synth (Blofeld desktop).

In my head (which may not even be possible), I want to add the Blofeld as an external instrument which then records a certain and sound. then add another blofeld instrument (from the same synth) but record a different sound.

Otherwise, I would have to create parts singularly and then render them out before repeating the process. In otherwords, is it possible to have multiple instances of the same synth using different patches from that synth?

As the Blofeld is multi timbral, I wonder if there is a simple way to do this.

I supplied the answer already. Which part of my answer don’t you like?

I don’t understand the answer. I wouldn’t know how to do that.

Are you saying create a midi track with each track having a different midi channel? In which case I assume you can’t use external instruments to achieve this?

Yes.

Correct. You can only have one instance of an External Instrument track.

Here is a picture of what it looks like:
grafik

The first patch in Blofeld would be addressed by the Instrument track. any other patch is addressed through MIDI tracks, whose MIDI output is set to the external instrument (in your case Blofeld).

Hi Johnny

That all makes sense. Thank you so much!

Bit confused though before I saw this I tried making multiple MIDI tracks for the same synth and I assigned a different patch to each different channel.

For example -

MIdi track 1 channel 1 - Bass
Midi track 2 channel 2 - synth lead
Midi track 3 channel 3 - pad

However, although I can set different patches to different channels, let say I’ve set the bass up on Midi track 1 channel 1. it updates to the bass patch on the Blofeld. As soon as i setup midi track 2 and assign the synth lead patch, the Blofeld updates automatically to the synth lead patch. But when I go back to Midi Track 1 although cubase says Bass, it doesn’t change on the Blofeld and stays as synth lead. In other words, the tracks do not update the synth when you switch between them - and thats a killer for workflow becuase you’d have reset the patch every time you switched tracks for recording.

Will this also occur in your solution or is this happening because there is a problem with my setup?

Best wishes

John W

This happens when the tracks in Cubase have the same MIDI channel assigned. You have to make sure that they use different channels. Imagine a house with several appartments. A MIDI channel is basically the appartment number.

Furthermore - when you change a patch Cubase sends a program change message to the Blofeld. When you just select another track no such message is sent. So what you describe is just normal old school MIDI behaviour. Unfortunately it takes a bit of effort and time to “learn and understand MIDI” and most users that started with DAWs well after the 2000’s did not see the need to get into this topic anymore since everything works so nicely in the box.

If one would make a survey amongst Ableton Live and FL Studio users about certain things regarding MIDI like a program change and ask them how it works I would not be sursprised if >90% had no idea what you are even talking about.

But if you work with an external hardware synth it is a good idea to dive into the topic.
BTW - I use this site whenever I need to look up details of MIDI. It is so old that it doesn’t have a https site (browser might give a warning) but MIDI is also old, so it’s not outdated.
MIDI Specification

1 Like

Thanks again - it’s really helpful.

As I am a newb I’ll ask the dumbest question ever, although I do get the logic. Where do you change midi channels. Do you set a different mid channel for each midi track and if so where do you do that? Is there anything that needs to happen on the Blofeld?

I don’t know how to set midi channels in Cubase - it’s all Greek to me at the moment.

I will take a look at that website though - again most helpful.

regards

John W

Is this the Midi channel? If it is then my routing is wrong becuase it didn’t work (as per my exmaple in my previous post).

Yes.

You should see multiple channels to choose from.

Yes, this is where you can change the MIDI channel. And you can also see the “1” on the selected track itself.
If it does not work please post a screenshot showing the same things as my screenshot above. Maybe we can spot any missing settings.

Thank you. I’ll take a look and post a screenshot showing how it’s set up.

regards

John W

So it didnt work. Here are some screenshots:

image

Instrument Track (patch = Leaderich 2)

image

Midi Track 1 on channel 2 with patch Pussy Galore

image

Midi Track 2 on channel 3 with patch LA Woman

image

Midi Track 3 on channel 4 with patch Drive Sweep

Every time I add a midi track and change the patch name the Blofeld changes. But if I then move to a previous track, although the name in Cubase is correct, the Blofled does not update with the patch change.

Any ideas??

regards

Johnny Winto

Just so that I understand this correctly, after you’ve added the third MIDI Track, MIDI channels 1-4 all play the “Drive Sweep” patch? Even if you enter MIDI data on the 4 tracks?

Have you put your Blofeld into Multi-Mode?
grafik

If so make sure to set up your Blofeld parts to individual channels:
grafik
grafik