External Tool Close Active File

I set up RX4 as an external tool for audio files, and selected “close active file” in the external tool setup. But it’s not closing the active file when it opens RX. Can that be reproduced? Doesn’t seem right.

I’m using the factory argument “active file name with its path”. It sends the whole current file ok (is there anyway to send just a selection?), but after editing in RX, I tried “overwrite original file” in RX, but RX says the file is open in another app. Is there anyway around this to receive the edited version back from RX?

I just wonder how other programs can do this without using the RX Connect Plugin, unless that’s a function of communication included in their specification of the external tool as an “External Editor”. If so, is there no way to do that with the external tool setup in Wavelab?

Also can you set up a shortcut key for an external tool?

“close active file” does its job here, using 9.1.

Is there anyway around this to receive the edited version back from RX?

You need to reopen the file “manually” in WaveLab.

can you set up a shortcut key for an external tool?


I think REAPER can do something similar to this because if REAPER isn’t the focused app, the files go “offline”.

I can send all or part of a file to RX from REAPER (without using connect or any plugins), do the edit in RX, save/overwrite original file and when I CMD + Tab back to REAPER, the edited file is present in REAPER and ready to go. On to the next edit.

Now that I think about it, I remember trying something similar in WaveLab once but WaveLab didn’t know the file was modified and I had to close and reopen the file/session in WaveLab.

Thanks PG. I’ll try again to see why it’s not working here.

So the communication between Reaper and RX is more complex and sophisticated than between Wavelab and RX? I still wonder why. The arguments sent ?, and …?

Reaper does as WaveLab. The only difference, is that Reaper reopens the file.

I’ll have to look closer at this External Tool when I get a chance. Is it possible to send an audio file or part of an audio file to another app to be edited?

PG, it’s because of the way I was trying to use it (which is actually the way I would use it if it worked).
I start from the montage. I either create a segment in a clip and clone and substitute, “edit source”, or “edit source” of the whole clip. That opens the audio file from the montage. Then selecting the External Tool (which has “close active file” selected), it doesn’t close the active file.

Also, if I just open an audio file (no montage open), and select External Tool, it closes the active file and opens it in RX. Then I modify the file in RX and try to “overwrite original file”, but RX still says it’s open in another program, and I have to quit Wavelab to save the file. Wavelab seems to be still holding something open somehow.

However, having said all that, I don’t really have a problem using the RX Connect plugin, and it does everything I want, even automatically updating the segment back into the open clip in the montage. But it would be nice if the External Tool could do that.

The problem is that montage referenced files are kept opened in WaveLab.

Hi Bob,

How are you configuring the External Tool to get it to work? I keep getting an error message but I admit I have not read the manual yet.

I do agree that it would be nice if it were more streamlined like REAPER.

It would be nice to go direct from the montage if desired:

Highlight section in montage
Use External Tools to open a copy of that section in RX
Performs the edit
Save the original file in RX
Return to WaveLab montage and that section is seamlessly spliced into the montage, but the audio file was a copy so that you can always go back to the original.

The copied audio remains in the same folder of the main project for easy file management and archiving.

Sorry, I meant to attach what I have been trying to do and the error message I get:
Screen Shot 2017-09-17 at 7.21.42 AM.png
Screen Shot 2017-09-17 at 7.21.25 AM.png

On Mac, I think you should give the address of the application inside the app bundle, not the app bundle itself.

That doesn’t seem to be the problem that’s causing RX not being able to overwrite the original file. That happens even if a montage was never opened.

Open wavelab.
Open audio file.
Run external tool RX (“close active file” was selected in the RX ext tool setup). Wavelab closes the active file and opens RX.
Edit file in RX.
Attempt “overwrite original file” from RX File menu.
RX says file is open in another app, and can’t overwrite the original file.

But if you then quit Wavelab, you can overwrite the file from RX.

Something in Wavelab is still holding the file open, even though Wavelab supposedly closed the file when it opened RX.

Something’s not right there.

You are right, there is a bug. The best work around:

  1. Don’t active “Close File”
  2. Run the External Tool
  3. Close the file yourselves in WaveLab (no need to quit WaveLab)
  4. Save the file in RX
  5. Reopen in in WaveLab from the Recent File menu

Thank PG. That sounds like it’ll work in the meantime.

Testing how this all works in Wavelab, looking at Justin’s request, it still doesn’t work from the Session as in Pro Tools and Reaper. You can’t send and receive directly from the Wavelab Montage like you can in Pro Tools and Reaper. And you can’t send and receive just a selection of audio from the montage, like you can in the other programs.

You can’t send directly at all from the montage in Wavelab, even with the RX Connect plugin. You can only send from Audio Files. Although you can send and receive just a selection of an Audio File with the RX Connect Plugin in Wavelab.

I know, all this is under consideration.