External USB hard disk problem


I have recently bought a Seagate Expansion 2TB USB 3 drive for all my cubase projects.

When I record and playback new project or playback older projects copied (or back-upped) to the disk the following problem occurs:

One or more audio tracks don’t playback but will randomly send clicks or a few seconds of loud noise to the output (only my right channel). If you solo the problem track it does the same. When I play the wav recording on an external audio player (windows media player for instance) it plays correctly.

When I copy the project to one of my internal disks it plays fine with no problems.

Does anyone know what might be happening here?

It happens both on my old cubase 5.5 and the cubase 7 Elements trail version.

Kind regards,

Are you also using a USB audio interface? If so, the USB 3.0 hard drive and the audio interface may by competing for USB time.

Unless you have 200 audio tracks playing at the same time, there’s plenty of bandwidth in USB 3.0 to go around, so resource starving in this case is not a likely culprit. Let’s see what the possible scenarios can be:

  • USB 1.1 interface (like M-Audio Fast Track) on a USB 3.0 port: recipe for disaster
  • USB 2.0 interface on a USB 3.0 port: it can cause problems, especially on macs
  • Some kind of interface issue

Anyhow, as a general rule don’t use USB externals as audio drives. That includes USB 3.0. I use my USB 3.0 drives only for backups.


Thanks for the replies. The Audio Interface is also USB but this cannot be the problem because when I use another USB harddrive I works just fine.

It could be the large size of the drive or just something with the drive itself. I have posted this problem at the seagate helpdesk, maybe they know what causes this problem.

On the web a lot of people say it is preferable to have an external hard drive for your recording because this relieves the load on the system disk (e.g. http://www.homestudiocorner.com/12-home-studio-necessities-7-externaldedicated-hard-drive/ ) . I haven’t Read anything about not using USB for that.

If I get some response from Seagate I will share it here.

As I understand it, an internal, dedicated project/sample is better than an external one. But of course it depends on how many audio tracks you’re running, if you have just a few, the difference may be negligible.


Is the other external drive (that works just fine) also a USB 3.0? USB 3.0 drives can be lightning fast which, of course, means they are very high priority on the USB.

Hi, how long is your cable? Have you tried a different one? Is it a USB 3.0 cable?

I had this exact problem with a WD Elements 3T USB drive and it turned out to be the 3m USB 3.0 cable I was using to connect to my MacBook Pro. I tried the original WD (which was too short for where I wanted to locate the drive) and everything worked fine. I then tried a 2m cable and that was OK as well. It seems some drives are more fussy with cable specs than others.

It’s correct that the audio drive should not be the OS drive, but it’s always better if it’s an internal drive. Externals are prone to a lot more problems, especially with USB (including USB 3.0, which unfortunately shares the USB 1.1 and 2.0 controller on your mobo.)

Ideally, your audio drive should be a SATA III SSD. If you don’t work with a million audio tracks, a 256-gb SSD will do just fine, and those are pretty cheap nowadays (as in a decent one for around $100. Check with newegg.com.)

I have the same issue (glitches and pops when streaming from a USB3 drive) with 3 different USB 3 drives (all from different vendors) on both my Win7 PC and Win8 Laptop. I’ve been streaming from a USB2 drive for about 5 years with no problems at all and I just tried another USB2 drive and that was totally fine too… Seems odd that I can replicate the issue across my PC and Laptop but so few other folks have noticed it?

I have the same problem. Win7. Soundcard - PCI. 2 different USB3 drives, one of them works ideally, and second one with glitches and pops. Does anybody knows how to fix it?

Same problem here, running Windows 7 64 bit and Cubase 7.5. Projects work fine running from my internal hard drives or my USB 2.0 drive but not when running from my USB 3.0 drive (clicks, silence and occasional loud noise bursts). I thought it had to with that I was using my USB 3.0 drive with a USB 2.0 port, but having installed a new Transcend PCI-E card providing USB 3.0 ports I still have the same problem.

Hi Guys,

I found this post as I was having the same problem.

At first I thought the project was corrupted. It worked on the HD but not on the USB drive. I have done a lot of work in the past exclusively on a WD My Passport USB3.0. I’ve never had a problem.

The problem I am seeing/hearing is missing tracks on playback, lots pops and hissing noises and disk cache indictor on the transport acting very erratically with lots of redline peaks.

So I did some testing. My test project had 11 active tracks of audio and a midi drum track. The disk load averages about 7MB/sec.

I have five different USB3.0 drives and copied the project to each. Two WD My Passport drive. One WD desktop drive. And two Seagate desktop drives. I tried various combinations of cables and drives. In the end it was only drive that had a problem. The other works without issue. I tried defragging and optimizing the drive and it continued to fail.

The drive is a Seagate Backup Plus Desktop Drive 1DXAP3-500 3 TB

So although this drive appears to working, there’s something marginal about it, or some kind of compatibility issue between and Cubase. (Using Artist 7.0.7 build 2277)

I’ve always had a good experience with the WD My Passport drive and get my clients to purchase one for backups.

BTW On PCs the USB 3 connectors are blue. If you are using a black connector your will not be running at USB 3 speeds.