Extremely laggy when zooming in with large audio files

I’m working on editing a few long DJ sets again and Cubase is getting really annoying!!!

When zooming in with large audio parts in the arranger, everything get so laggy that it’s unusable. I’m used to a fast snappy workflow of scrolling, holding ctrl, shift, mouse wheel etc but everything simply pauses! I find it very hard to believe that Cubase can’t handle this being a lot of users do long sessions and it’s not simply for 3 to 10 minute songs.

What is going on here???

The PC is a fast i7 5.0. Plenty of RAM free. Nvme SSD.

I did make a post about this some years back last time working on such jobs and nothing has changed.

Please help Thank you

There is something fundamentally wrong with the graphics engine.
I have issues with certain plugins not showing their UI and with other plugins, when they are open, my whole pc is stuttering, even on a nearly empty project.

In other daw’s i’ve tested, these problems don’t exist, so i can only boil it down to something being wrong with the graphics engine.

Under normal circumstances for a song length project, everything works (well not quite everything, there are some other known issues), however… it’s just any project with an extremely large audio part, which I find very bizarre that Cubase isn’t designed to handle zooming in close on these. This made me presume I have a graphics driver issue, settings conflict or something.

This glitch is a complete show stopper for me!!!

I will do some testing once I’ve finished todays duties and see what length file starts the issue. Likely another late one!

Thank you cbm1 for your reply