F#%king dongle

Trying to start work this morning. Turned on the hardware and launched N11. Got an error message saying no valid license (WTH?)!

Went to eLicense Control and it said I needed to update the license. Okay. It went through the process and gave a couple of more error messages. So I ran maintenance. 5 out of 6 tasks were successful. Updating the license failed.

So I re-seated the dongle. That usually works in extreme cases like this. Tried to run maintenance again. Got another error message telling me to use the recover option. Then EVERYTHING ON THE DONGLE DISAPPEARED!! :scream: Now nothing works! I can’t use recover function because all functions are greyed out.

Went to SB support to put in a ticket and the site crashed! guess how pissed off I am right now! :rage:

…and just like that, everything came back. I didn’t re-boot. I didn’t do anything. I just lauched e-license again and everything was there! :flushed:

Ran the recover function and it said there was NOTHING WRONG! Ran maintenance and everything went through. So I tried to re-start my morning. Hardware and Software all fired up like nothing had happened. :triumph: Of course, now my nerves are shot.

They have got to find a better system that works for US as well as them!

This sounds like a USB port physical connection problem. Please, be careful about your blood pressure.


Is this what happened to him? Exact same blank screen as mine, only I never removed mine until I HAD to re-seat it.
Thanks for your concern.

I don’t know, and with the info you have given it would be impossible to tell.

But when a problem like that pops up, before I do anything else I restart my machine, and plug the device into another USB port.

Note also, that if your browser tab shows a crash on a particular site, it’s not the site that crashed, it’s the tab. Were the Steinberg website actually crashing there would be dozens of angry posts. But there are only the normal amount of angry posts today. :stuck_out_tongue_winking_eye:


true, in my case only happened with the shorter blue dongle … i forgot which one is newer the longer or the shorter, but yeah it keeps happening …

1 Like