Faderport Classic Question

I am able to install and use my Faderport in Cubase 11, as I was able to in 10.5. The problem though is that each time I add an Instrument Track to my project the Faderport disappears from the list of “Remote Devices” and has to be added again. (This was also the case in 10.5)
Is there something that I’m missing, or is this some kind of bug in Cubase? It does integrate well into Cubase, but it’s annoying to have to add it each time I add an instrument. (If I add an Audio or Midi track the Faderport remains active)
Thank you,

I have tried this, and this does not happen in my Cubase 11. On the other hand I don’t see Faderport as a separate devise in the “Remote Devises” window - Faderport uses the devise “Mackie Control” to connect to the Faderport as described in the Faderport setup manuel.

I use the Faderport .dll which I copy into the Steinberg Components folder for each Cubase version I upgrade to (Windows) not the Mackie HUI. It works perfectly on all versions.

Thank you for the replies. I have used the Faderport using the Mackie protocol but I far prefer it as its own entity. There was a trick to get it to show up as a remote device, but it’s been a while and I totally forget how I did it (currently on Mac OS Catalina).
It works perfectly once I add it as a remote device. The crazy part is that it disappears from the list of Remote Devices when I add an instrument track. I am able to add it again after that, but I need to do this each time I add an instrument. When I add an audio or midi track the Faderport remains active. Strange behaviour.


Odd behaviour, but I have heard of others with a problem like this on Mac in which Faderport needs to be reloaded on each boot, I can’t help you directly as I am on Windows.

I have one offbeat idea for you to try though, It’s simple (and possibly stupid). Set the Faderport.dll attribute to read only. I did this on my system and everything still works. Just possibly it might prevent other parts of the program interfering with it? Do let us know if by any chance it works on Mac.

I’ll list the steps I use at each Cubase update below. It might help someone else out as it integrates better than Mackie HUI.

Put a copy of the Faderport .dll (usually i just copy from the previous version) into Cubase xx Components folder, which on Windows systems is located C: - Program Files - Steinberg - Cubase xx - Components. Start Cxx then go to Studio Set Up - + Device, then select Faderport from the list. The integration is perfect and works a treat with my Softube Console 1 too

Thank you Parrotspain,
Thank you for your reply. I’m not sure what the Mac equivalent of a .dll file is but I’ll do some thinking and looking and see what I come up with.

I had this problem and it was so maddening that I bought a CC121 a few weeks ago. I couldn’t solve the mysterious disappearing Faderport, and it became too much to deal with.

That said, I can’t imagine working without the CC121 now. Its annoying as hell that the faderport isn’t really supported, but if its an option, the CC121 is a really nice upgrade with some incredible time saving features.

Ya, the CC121 would be great for sure. However, I split my time between Cubase, Logic Pro and Studio One, so the Faderport is the best option for me (in spite of the disappearing act).

Same problem here, Mac OS Catalina.
I tried to set the Faderport.dll to read only. Didn’t solve the problem but made Cubase not to close properly - it hangs.
Strange thing is, that once you setup the Faderport and then restart Cubase it seems to recognise the Faderport as it initialises it…