Fail to setup NanoKontrol 2

Hello,

after upgrading to Cubase 10 PRO on Windows 10 PRO, I tried to setup my NanoKontrol2 but it does not respond correctly.

Driver is correctly installed. Follwing up the instructions, I connected it while pressing Set + Rewind button, then added a Mackie Control so I could insert the Nano in midi in and out.

It’s supposed to work but nothing happens. I’ve got only the white led dispaly that just shows me that the machine is connected.

Has anyone of you had a similar problem and found a solution?

Thank you so much for helping out

Hi,

Have you set the MIDI In and Out in Cubase > Studio > Studio Setup > Remote Devices > Mackie Control? What kind of MIDI Port have you used?

Yes indeed. As explained, in studio device, I added Mackie Control and in input / output I picked the Nano Kontrol 2 from both drop-down menu is.

Thank yoi

Hi,

Could you attach a screenshot, please?

When you press a button/move a fader on the nano Kontrol, can you see incoming activity in Cubase?

I will as soon as I am in my studio, thanks for asking.

I do not see any incoming activities by the way. Only the light led on top left corner is one, but it just mean this devil is plugged. Apart from that (after following all the procedures) nothing responds. Neither the lights in the Nano respond nor anything in Cubase gets triggered.

The only things that flash the red light are the buttons pressed before plugging in the Nano. Eg. if I press Set + Rewind button while plugging the Nano, the Rewind button just flashes a couple of time, then it dies again. Same thing if I try other combos as Set + REC button: the REC button will flash a couple of time, then adios.

Also the Korg Editor seems not working properly, but I never understood this software and back in 9.5 I didn’t even open that thing.

Thank you for your time, hope it clarified a bit before the screenshots

Hi,

If you can’t see any incoming MIDI activity, I’m afraid the problem is on nanoKontrol side. It seems, it doesn’t send the messages (or the system doesn’t receive it). Try to connect nano Kontrol to other USB port (the best would be USB 2), try different USB cable.

Can you see any incoming MIDI activity, when Mackie Control has no selected input in Cubase?

Thanks for that Martin. I’ll try different USB connections. Since the white led light on top left was on, I thought that at least the connection was fine (if it were broken it’d be off I guess). It worked absolutely fine on Cubase 9.5 Artist, now I upgraded to Cubase 10 Pro and I’m experiencing this problem. That’s why I believe the Nano’s still working properly.

Concerning your question, how can I trigger activities with nothing selected in mackie control, I’m not really expert with this feature.

Thank you again for helping out

Hi,

You wouldn’t trigger activities, but you should see an incoming MIDI signal in the Transport Panel (or Lower Zone) on the right side. See MIDI In Activity here.