Fantom does not show up in ASIO devices to select as audio interface

Hey, guys.

I just got a Fantom 6 that I’m setting up. I’ve installed the Windows 10 usb driver, Windows recognized it and set up the device. Fantom-6 7 8 is showing up in device manager under “Sound, video, and game controllers.,”

However, when I go to Studio to change my audio interface from my Focusrite to the Fantom, the Fantom is not in the list of ASIO devices.

Does anyone who uses a Fantom have suggestions on what might be going wrong here?

Windows 10, Cubase Pro 11.0.



Is it an ASIO driver?

It’s unclear from the Roland site. However, I’m making the assumption that it is because I’ve seen references to others being able to use it with Cubase.

Eventually I tried the drivers on a different computer and everything worked fine, so the problem is clearly environmental with this particular Cubase and / or Windows install.

One factor may be that I first auditioned a Fantom 06, then bought the Fantom 6 instead. That might have hosed things, as on the second computer I only installed the Fantom 6.