Fast track pro not working

Hi,

I’ve used Cubase for a couple of weeks with my fast track pro, now. Suddenly it started crashing on start up/not responding out of nowhere. I tried to reboot, and turn of the fast track and got in, but it would start with the interface turned on. I turned it off in devices, but whenever I turned it on again I would get a problem message, see screenshot.

I’ve had some problems with the card where it would make all the sound in windows go at half speed, but it has stopped. Think i reinstalled the driver, but I’m not sure. Then these problems started.

I’ve tried re installing the driver, but I can’t delete it from the devices&printer> fast track properties tab. And a repair doesn’t fix anything. Do I need to format my system or buy a better audio interface?
Skærmbillede 2015-03-13 10.25.58.png

I used to have a FTP. When the migration to 64 bit happened, none of the 64 drivers ever worked well for me. I got frequent BSODs. I gave up on it. HTH.

Mostly, I think the problem will be at setting. Once recheck it and fix them properly without loose connections.