Feature Request: Auto Note Spacing (Finale)

Hi Folks!

I’m wondering if Dorico ever intends to implement auto note spacing like in Finale? In general, Dorico does a great job automatically spacing notes. However, there are times when the lyrics get compressed to accommodate note spacing.

In Finale, you could just press Command+5 (or 4, I can’t remember) and it would update the note spacing to make the lyrics look cleaner. It would be wonderful to have this option in Dorico (unless it’s already there and I missed it!)

So appreciate the help and quick responses to all of my forum questions!

  • Ethan

Dorico’s designed to make these decisions on the fly. Pressing a button (or typing a shortcut) to recalculate is kind of the opposite of that. Either way, this is kind of irrelevant - it’s just a case of when the program makes the calculations to follow its own rules.

Let’s figure out why the rules don’t do what you want them to do:

What are these Engraving Options set to?

Engrave > Font Styles > Lyrics. What’s this set to? Could you get away with something slightly smaller or a slightly narrower font (Academico’s great but fairly wide).

Have you forced the casting off?

(P.S. Isn’t Carole King a wonderful songwriter? I might listen to Tapestry on a long car journey tomorrow :smiley: )

1 Like

In Finale, Command 4 is “Apply Note Spacing” and Command 5 is “Apply Beat Spacing”. Neither is guaranteed to make the lyrics cleaner. Dorico is ALWAYS automatically applying Note Spacing for you!

I’m surprised that Dorico produces the results you’re seeing: are you sure you’ve got “Make Space for Lyrics” checked in Layout Options > Note Spacing? It looks like Dorico isn’t giving the lyrics any space at all.

Also, this could be caused if you’ve set System Breaks. (If you’re from Finale, you’re probably used to Locking every system, which is not something I’d recommend in Dorico.)

1 Like

Here are my settings:

I tried making them smaller, setting them to the values you showed above, but my Section C isn’t looking much better. I did set the casting off, fixed at 2 bars per system!

Here’s the project file if that helps: So Far Away Choir Score.dorico (2.5 MB)

Thank you! Yes, Carole King is awesome!

I do have “make space for lyrics” checked on. I’ve only set 1 or 2 system breaks manually, otherwise I just have the casting off fixed to 2 bars per system

Engrave > Note Spacing mode (the fourth icon down the left side of Engrave mode) tells me that Dorico considers this system to be 117.8% horizontally full.

Dorico just doesn’t have space to do a better job with the spacing here.

You could turn down the space (staff) size, or you could reduce the size of the lyric font, or you could use a narrower font, but as things stand you have a mismatch between your settings, your casting off and what’s actually possible.

1 Like

I’d use Rastral Size 5, which gives you more space but is still very readable. In fact, you could go ‘custom’ a little bit smaller.