Feature Request: I want to be able to compare A/B the live input stream with already recorded tracks

A couple feature requests all tied up in one here…

  1. I want to be able to enable/disable live input with a key command… how do I do that?

  2. I want to be able to enable/disable live input while playback is happening at any time (without stopping Wavelab playback)… If I’m listening to the reference track in Wavelab, then I want to be able to A/B the reference track against the live input. If I’m listening to a standard track in Wavelab, then I want to be able to A/B the standard track against the live input.

The new reference track is a great idea for doing A/B of already recorded material (although it’s not working correctly for me yet). I’m having the same problem with it this guy is: https://www.steinberg.net/forums/viewtopic.php?f=297&t=176518

Thanks,
Todd

There is no shortcut and you can’t enable/disable live input without stopping (yes, a shortcut would be welcome)

What you could do, instead, is to use an audio montage with the track monitoring function. In that case, you have shortcuts and operations don’t cause playback to stop.
One one track you have some audio file, and on another (reference) track, you have no file, but you use the monitoring option to monitor whatever audio input you choose.

Something like that:


Toggle the “Listen” (blue) button allows you to A/B the top file and the live input.

Ok - I will try this… but at the moment, the reference track is broken, so I cannot even try (https://www.steinberg.net/forums/viewtopic.php?f=297&t=176518). I will try this idea though once it’s fixed…

I think I know the reason of the problem. Here a way to solve it: go in the Audio Connection Settings.

  1. In the Playback Tab, delete any bus you could have.
  2. Then add a second bus
  3. Click on the 1st bus, and delete it.

At this stage, you should have a single bus, with the label “Speaker Arrangement #1”, greyed, in the Categfory field,
below the bus box.
Assign the audio ports you need.

Now try again using the reference track…

Just tried it… unfortunately, it didn’t work…

Hmm, yet, I am pretty sure the audio connection is the source of the problem.
Try this:

  1. Erase this file: AppData\Roaming\Steinberg\WaveLab Pro 10.0\Presets\Audio Connections.last
  2. Launch WaveLab, and create a new montage (the old montage probable has stored a wrong audio connection ID).

YES!!! It fixed the problem!!! It’s working!!! Thanks PG! I’m up and running!

I just tried your idea here… It works GREAT!! I’ll be using the idea tomorrow all day to master an album in Wavelab! Thanks PG! Wavelab 10 is really rocking over here so far!! I’m psyched!!!

-Todd

Hey PG,

I just started up Wavelab today, and apparently it somehow recreated the incorrect connection again… so the problem is back. I tried deleting the file again as you suggested, but for some reason, today it does not seem to be fixing the problem… So the problem persists… I cannot use the reference track.

Thanks,
Todd

it somehow recreated the incorrect connection again

Did you modify the audio connection settings in any way?

No… It just didn’t work when I started Wavelab this morning, but it was working last night. So I tried deleting that file again, but now it doesn’t seem to fix the issue…