Fermata hidden, when rests join

Hi, I don’t know, if I miss a setting. In this piece, I would like to show the fermatas for both voices, but I would like to hide the second fermata, where the rests join the same position.


Also, I don’t know, why the fermatas on the lower voices are moved to the left in case of the rests?
Any suggestions, how to get rid of the unwanted fermatas? At the moment I am dragging them off the page.
Btw.: The systems are condensed.

There are engraving options for how many fermatas per staff; but I don’t know if that aplies to Condensing as well.

But those settings apply for all staffs. I want to keep two fermatas, where there are notes. I just want to get rid of the second fermata on the same rest.

for this question see Fermata position - #10 by MilosBetko